10

Attempting to run SSIS packages using dtexec.exe, I got this error message:

Could not load package "D:\Filename.dtsx" because of error 0xC00160AE.
Description: Connecting to the Integration Services service on the computer "" failed
with the following error: "Access is denied."

By default, only administrators have access to the Integration Services service.  On
Windows Vista and later, the process must be running with administrative privileges in
order to connect to the Integration Services service. See the help topic for information
on how to configure access to the service.

Typically for Microsoft, there's no clarification about which help topic has this information. Certainly the dtexec /? help does not.

Running dtexec from a command prompt launched with admin privileges, or from an application with admin privileges, did not resolve the problem.

14

I eventually found the solution on MSDN. To grant users rights to the Integration Services service:

  1. Open Component Services; from a Run dialog, you can enter "dcomcnfg".
  2. On the left-hand tree, navigate to Component Services | Computers | My Computer | DCOM Config.
  3. Find "Microsoft SQL Server Integration Services 12.0". This is for 2014; I believe earlier versions leave out "Microsoft," so check under "S" if you don't see it under "M".
  4. Open Properties | Security and for each type of permission hit Edit and add an appropriate AD group or user. Be sure to check the specific permissions required, such as Remote Launch when editing Launch and Activation Permission. If anyone knows exactly which permissions are necessary for running SSIS, please share.
  5. Launch Services, and restart the SQL Server Integration Services service.

You should now be able to connect to Integration Services from within SQL Studio or dtexec.exe.

  • 2
    This works. I only need to enable our service account to have a LOCAL ACCESS under ACCESS PERMISSION section. – Eve Feb 24 '17 at 6:17
  • The security tab is all greyed out for me. Not sure why. – mt025 Oct 16 '18 at 10:43
  • @mt025: are you a local administrator? – Jon of All Trades Oct 16 '18 at 13:44

protected by Community Aug 23 '17 at 21:37

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.