We had our MySQL server on an old server. We decided to move all of the databases to our new server.

  • Old MySQL Server engine 5.5.31
  • New MySQL Server engine 5.5.38

We created one general dump file without logs from all of the Databases in the old server and we restored the .sql file in the newly created MySQL Server on the new server.

On the new server when we put skip-name-resolve option in the my.ini everything is fine but we can't login to MySQL server with root account.

We tested the issue on old server and we didn't have any issue with skip-name-resolve.

We removed skip-name-resolve option and we tried to login to MySQL server. after login when we tried to list the available users. Like previous MySQL server here after restoring the dump we have two root users when we execute:

select user,host from mysql.user;

For the first one % is defined as host and for the second one LOCALHOST is defined as host.

All of the users are defined with % as their host. We want to use skip-name-resolve and on another hand resolve our issue with root account.


The issue may be that you have 2 entries for root, and that root@% doesn't have the same password as the root@localhost. Changing options may change the order MySQL uses each entries.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.