1

I ran into this error earlier today and requested that the extra logs be purged from the server. It was done but it still claims that there isn't any room. Is there a way to notify the server that it has more room than it thinks?

  • also check your file system if it has space to write the archives – tesla747 Oct 22 '15 at 4:03
2

You should purge the archived logs with RMAN:

RMAN> delete archivelog <delete conditions here>;
RMAN> crosscheck archivelog all;

or alternatively all of them:

RMAN>delete archivelog all;

You can check your recovery area usage like this:

SQL>select * from v$flash_recovery_area_usage;

If you encountered that problem though, you will very likely encounter it again. Purging the archived logs is a quick fix.

Whoever maintains the server needs to verify:

  1. That archived logs backups are performed and are successful
  2. That obsolete archived logs are deleted
  3. That obsolete backups are deleted.
  4. If the backups are performed regularly and obsolete archived logs deleted, maybe the database usage has increased and filling the fast recovery area faster than the archived logs get backed up. Increasing the db_recovery_file_dest_size parameter to a higher value to fit the business needs may be required.
| improve this answer | |
1

As SYSDBA:

alter system archive log all;

then:

alter system switch logfile;

Before those two steps, you may also need to do a crosscheck archivelog all in rman so that it "knows" that the deleted archivelogs have been removed (depends on how they were removed).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.