0

I've increased MEMORY_TARGET in pfile and then create spfile. I'm getting the same problem as before:

ORA-00838: Specified value of MEMORY_TARGET is too small, needs to be at least 3084M

The memory_target in pfile is 3084M.

I've already increased tmpfs on /dev/shm to 5Gb. And no idea what to do next?

2
  • Can you give us the following information in your question: "show parameter memory", "show parameter target", the output from "df /dev/shm", the exact command you run to start up your instance, the output from this... in short, anything more than what you've given. – Phil Sumner Oct 1 '14 at 9:31
  • Also, are you running a RAC database? – captjackvane Oct 2 '14 at 14:46
2

Set MEMORY_TARGET to at least the recommended value.

SQL> CREATE PFILE FROM SPFILE;
MANUALLY EDIT PFILE & CORRECT MEMORY_TARGET VALUE
SQL> CREATE SPFILE FROM PFILE;
SQL> STARTUP

What OS are you using?

0

The parameter MEMORY_TARGET is for how much physical memory Oracle can use on your machine hosting the Oracle instance; increasing tmpfs will not solve the problem; I would suggest setting MEMORY_TARGET to a little higher than the amount suggested by the error message; perhaps set it to

MEMORY_TARGET=4G

Assuming your machine has over 4 Gigabytes of free memory when Oracle is not runnning! 4 gigabytes is actually pretty small; I would set it higher if your machine (Unix? Windows?) has more free memory available.

0

check your memory target if your memory target is smaller than the sga_target as defined in the parameter file then you will get the above error. My scenario:

I have altered the sga_target using alter database set sga_target=2G scope=spfile now when I tried to again open the database I was getting the same error. So I checked my memory_target which was 1G.

So I remove the spfile first and then set my sga_target as 500M and startup the database with pfile and then created spfile from pfile.

0

If using Oracle 18c XE Database to install the latest version of apex then Open cmd and then cd to database home directory\bin

    cd D:\app\Administrator\product\18.0.0\dbhomeXE\bin

Now type the following:

    sqlplus / as sysdba

If login successful then type the following

    create pfile = 'D:\app\Administrator\product\18.0.0\dbhomeXE\admin\init.ora' from spfile

Open file D:\app\Administrator\product\18.0.0\dbhomeXE\admin\init.ora using notepad Modify value for memory_target=0 Next, type the following

    startup pfile = 'D:\app\Administrator\product\18.0.0\dbhomeXE\admin\init.ora' 

Once the database is up type the following script

    create spfile from pfile='D:\app\Administrator\product\18.0.0\dbhomeXE\admin\init.ora' 

Note: You can use any directory to create the pfile e.g c:\init.ora

Finally Shutdown and restart the database again; To shutdown type (on sqlplus)

    shutdown;

To restart type (on sqlplus)

    startup;

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy