2

We are running 2 Microsoft SQL Servers - publisher (2008R2) / subscriber (2008 Express) with merge replication.

I tried to make some schema changes via Transact-SQL and partly failed. So tried to drop the offending table from the publication to make the changes but since then I keep getting this error:

The replication Merge Agent failed to propagate a Publisher schema change to the Subscriber.

I have tried reinitialising the subscription with a new snapshot and failed. I have upgraded both SQL Servers to the latest service pack. I used this to get outstanding schema changes:

EXEC sp_enumeratependingschemachanges 
    @publication = 'xxx_Publication'

then used this to skip the outstanding schema change:

EXEC sp_markpendingschemachange 
    @publication = 'xxx_Publication',
    @schemaversion = 1554,
    @status = 'skipped'

and it has gone from sp_enumeratependingschemachanges now. Then did new snapshot/reinitialisation but still getting the same error message!

Please can someone advise? Meanwhile there have been changes to both DBs that need to be synced back together.

  • The merge replication has been working fine for a year or so. You can specify the minimum server version level for the replication in the publication properties somewhere - which is currently set to Server 2008. – Barry Nelson Oct 9 '14 at 13:59
  • Are you using the Merge Agent -ParalellUploadDownload parameter and/or the High Volume Server-to-Server Profile? – Brandon Williams Oct 9 '14 at 16:28
  • No I am not, I am using the slow speed profile as its over a slow connection. – Barry Nelson Oct 9 '14 at 19:04
  • I know there is a bug when using the -ParallelUploadDownload parameter and/or the High Volume Server-to-Server Profile which causes the Merge Agent to repeatedly enumerate schema changes, even if you mark them as skipped. I'd be curious to see if you changed back to the default agent profile if the problem would go away. – Brandon Williams Oct 9 '14 at 20:09
  • I saw that bug too in my google research. I have swapped to the default profile but no change.. – Barry Nelson Oct 10 '14 at 7:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.