0

I have the following problem. I currently have to modify a .dtsx-Package which was originally created by a coworker who is not arounf anymore. This package contains some logic but above all it does the following:

  1. The Package contains some reference to xsd-files which provide a structure.
  2. Some XML-files are fetched and read based on the structure provided with the xsd-files.
  3. The process is supposed to write to several ADO destinations witch hold tables according to the data in the xsd-files.
  4. After the package retrieves and reads the xsd + xml files a merge join is applied and the data is supposed to be written to the database.

The whole thing looks something like this:

Note this is just a re-staged screenshot of the situation.

So the rest of the package is huge and it works fine. But for this one component I have had trouble for several days now. Here everything works fine, except for the Merge-Join node. normally if I open the editor I am always able to map the column names according to their names. In this case this very same window looks as follows:

enter image description here

As you can see there are no mapping possible as this dialog doesn't show any column names, so every time I try it nothing happens.

Any ideas? Note the very same procedure works throughout the entire package, it is only in this one task where it behaves kinda strange.

  • Something has happened such that the source column doesn't exist any more and the mapping is broken. In the bottom drop down, "spaltzenzuodnungsoption..." there should be 3? options. You want the one that says delete. This will remove all the mappings so you can start over. – billinkc Oct 21 '14 at 14:07
  • @billinkc This did work. To be honest I already tried that but it never gave me any feedback on whether it deleted or updated anything. This time I did it again, pressed 'OK' and opened the editor again. Now I was able to do a manual mapping. Thank you! Please Make your comment an awnser and I will mark it as such! – チーズパン Oct 21 '14 at 14:43
2

Something has happened such that the source column doesn't exist any more and the mapping is broken. In the bottom drop down, "spaltzenzuodnungsoption..." there should be 3? options. You want the one that says delete. This will remove all the mappings so you can start over.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.