26

I have installed PostgreSQL 9.1 on my PC (Win 7). I have a small Java application connecting successfully to it with login=sa and password="". The connection works.

However, it is refused from PgAdmin III itself. I get:

Error connecting to the server: fe_sendauth: no password supplied

How do I connect to my database from PgAdmin III with an empty password?

EDIT

This is just a test, not production code.

3

2 Answers 2

10

I can connect to my postgres instance from pgAdmin III without a password for any user including superusers such as postgres.

Because you are connecting ok from another client, there is no reason you should not be able to connect from pgAdmin if they are on the same workstation - unless some firewall rule on the client itself is allowing one program but not another.

If the problem is specific to this client, you may need to change one or more of:

  • pg_hba.conf
host    sa    all         192.168.0.nnn/32     trust
  • postgresql.conf
listen_addresses = '*'
  • the firewall on your postgres server, eg iptables:
-A INPUT -s 192.168.0.nnn -m state --state NEW -j ACCEPT

But I recommend you don't do any of this. The manual says the following with good reason:

trust authentication is only suitable for TCP/IP connections if you trust every user on every machine that is allowed to connect to the server by the pg_hba.conf lines that specify trust. It is seldom reasonable to use trust for any TCP/IP connections other than those from localhost (127.0.0.1).

Instead, consider either:

  • using a password and md5 identification
  • tunnelling port 5432 over ssh
33

I found this answer elsewhere.

If your DB is on the local host, try leaving the host field blank in the connection as opposed to using “localhost” or “127.0.0.1″. This tells PgAdmin to connect via the local unix socket instead of TCP.

5
  • Let's add that the original question was about a Windows system. Dec 11, 2012 at 8:38
  • 3
    Ah this was exactly it. Leaving host blank worked.
    – basicdays
    Apr 11, 2015 at 2:22
  • 2
    You cannot leave this field blank, it is required.
    – Athlan
    Apr 17, 2015 at 13:18
  • It looks like leaving the host field blank works only if you have a role in pg named as your system username (on Linux). Otherwise I guess user maps are needed.
    – a1an
    Aug 31, 2015 at 12:25
  • 1
    Perfect! With a fresh install of postgresql and pgadmin, changing pg_hba.conf to say trust instead of peer in this line - local all postgres trust, and leaving the host and password fields blank in pgadmin gets everything working! I wish pgadmin would add a checkbox to switch to sockets instead of this hard to discover UI. Dec 22, 2016 at 5:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.