2

I imported an SSRS 2008 Datasource to SSRS 2012 using RS Scripter tool.

The DB connection is the same for the SSRS 2008 and SSRS 2012 data source created.

I can 'test successfully' the login/pw for SSRS 2008 datasource, but 'fail' with SSRS 2012.

The login has permissions and exists (They are the same for both SSRS datasources)

Any suggestions on how to trouble shoot this? I asked Server Admins if there are firewall issues, they stated there shouldn't be any. I was able to ping both hosts (though maybe that doesn't mean much sometimes)

7
  • You should be able to manually create another data source on your 2012 instance. Just give it a different name. My hunch is that your script doesn't have the credentials correct. Oct 28 '14 at 8:48
  • Does your ssrs server have ssms? And can you log into it with remote desktop? If so you could connect to your source db from the server using ssms and your data source credentials to rule out firewall issues. Oct 28 '14 at 8:52
  • Hi @peter. Thanks for Suggestion, I tried manually created another datasource but still get error msg: 'Log on failed. Ensure the user name and password are correct.' when attempting to 'test connection' On older SSRS 2008 server I can create a new datasource using same login/pw but 'Succeeds' so I can confirm login/pw ok. Also on new server I can use my own domain login/pw 'Succeeds' this validates no firewall issues.
    – Normoe
    Oct 29 '14 at 23:57
  • Can you change the password for user data source just to rule it out? Does the password use unusual characters? Oct 30 '14 at 6:44
  • Can you confirm you're connecting from 2008 SSRS instance to remote db. And also from 2012 SSRS instance to same remote db? You're talking about 3 servers. Oct 30 '14 at 6:49
2

The issue had to due with Windows GPO it was unknown to me at the time
http://technet.microsoft.com/en-us/library/bb326317%28v=sql.90%29.aspx

1
  • +1 for Normoe. In my organisation we lock the Allow Log On Locally setting down, so the account I was using had to be added to the AD group allowed to log on locally. 30 seconds later all was well.
    – bytejunkie
    Jun 2 '15 at 12:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.