I've had the Ctrl-F1 query shortcut bound to sp_whoisactive for years (this technique is described in How to assign CTRL+F1 to sp_whoisactive in ssms 2012?). A few days ago, it stopped working. If I hit Ctrl-F1, SQL Studio now launches Books Online in Internet Explorer. Has anyone else seen this problem? Is there a fix?

I confirmed that the shortcut it still set. Changing the shortcut does not fix the problem, Ctrl-F1 still launches BoL. Cycling SQL Studio has had no effect.

FWIW, this happened after IT restarted the server while I was logged in, so SSMS did not shut down clean.

I can of course use another keyboard shortcut (though sadly it seems Ctrl-1 is hardcoded to sp_help), it just bothers my OCD to use a different shortcut for the same command on different machines.

1 Answer 1


Here's a long shot: I think your Management Studio has for some reason changed the keyboard mappings to the 2012/2014 default setup, which is more similar to the regular Visual Studio apps. This changed as of SQL Server 2012 so, among other things, Ctrl+F1 now opens Books On-Line.

To verify if this is the case for you, you probably won't be able to execute queries using Ctrl+E or view estimated query plans using Ctrl+L.

I found a way to reset the keyboard shortcuts to the "classic" setup and wrote a blog post about it a while ago. The short version is:

  • Open the "Tools" menu i SSMS,
  • Select "Import and Export settings...",
  • Select the "Reset all settings" option, click "Next",
  • On the last page of the wizard, you have the option to back up your current settings. I would recommend you to do this.

Hope that helps.

  • Thanks for taking the shot, but it doesn't look like this is the case: Ctrl-L still works. I may end up trying "Reset all settings," but there are a number of little things I like to tweak which I'd hate to redo if I can help it. Commented Oct 31, 2014 at 18:31
  • 1
    In the "reset all settings" dialog, there's an option to export your settings to an XML file, which you can then selectively edit and re-import. I use it reguarly to copy my settings across different SSMS clients. Commented Oct 31, 2014 at 18:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.