1

I have MySQL 5.6.19 running on Windows Server 2008 R2.

I have 3 servers A, B, C Server A is a stand alone server. This server had data that can't be placed on SERVER B (ie. users information.)

Server B is another stand alone server which has data that can't be saved on server A. Server B is a master of server C. Server C is another stand alone reporting server which is a SLAVE of server B.

After using adding FEDERATED table to server B. I re-sync server C "the the slave" to Server B "it's master."

But now server C will not start unless I add --skip-slave-start option.

In addition, whenever I issue START SLAVE; command on server C, this server stops working immediately (crashed.)

Something is going on with the replication. I must say that the replication was working before I added the FEDERATED table with no issues. (IMPORTANT NOTE: I did not issue any create table engine=FEDERATED while the replication is running. I first created all the FEDERATED tables on the master (SERVER B) and then I created a server backup and restored it into the slave (SERVER C).

In an effort to figure out what is causing this crash. I have added core-file to the file my.ini to get MySQL to generate core.pid file, but nothing was created.

I tried to add core-file-size=1GB but this caused the not to start at all due to unknown variable! (perhaps it is not recognized by Windows.)

What can I do to investigate this silent crash on Windows 2008 R2?

Thank you

1

I figured out a solution.

I run MySQL via the command line

I disabled this line log-error=.... from the my.ini file.

I stopped MySQL service. Then I opened a command line and run this

mysqld.exe --defaults-file="C:\ProgramData\MySQL\MySQL Server 5.6\my.ini" --console

This showed me that I run into a bug with MySQL

1

There is a bug in MySQL which causes MySQL to crash every time a flush tables is performed if you are using federated tables. This might be related to your issue as well since it is specifically an issue when using the federated engine.

https://bugs.mysql.com/bug.php?id=47525

There's a MySQL setting called flush_time and it defaults to 1800 (30 minutes) on Windows. This causes mysql to crash every 30 minutes. Since this setting is only recommended for low resource boxes, as long as you have a fairly decent box, the solution is to set flush_time = 0 in my.ini.

On 'nix boxes this value already defaults to 0 so this is a Windows issue only.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.