0

I've tried multiple times to install SQL Server 2012 on a 2-node cluster. I've tried multiple different media. Each time it hangs shortly after the initial validation check.

The detail log for the install has this for the last entry before it hangs...

(01) 2014-11-17 23:55:49 Slp: ----------------------------------------------------------------------
(01) 2014-11-17 23:55:49 Slp: Running Action: RunRemoteDiscoveryAction
(01) 2014-11-17 23:55:49 Slp: Running discovery on local machine
(01) 2014-11-17 23:55:50 Slp: Discovery on local machine is complete
(01) 2014-11-17 23:55:50 Slp: Running discovery on remote machine: NODE2

The same thing happens on NODE1 when it tries to install.

The only other google article I could find on this was an unanswered msdn article with almost the same description of my problem. https://social.msdn.microsoft.com/Forums/en-US/18018405-522f-4793-b5fd-a84835f15234/install-sql-server-2012-sp1-on-a-windows-server-2012-r2-failover-cluster-hangs-at-running?forum=sqlsetupandupgrade

I can ping each node from the other. The Cluster doesn't appear to be displaying any errors either. All nodes and networks are showing up and running in the cluster manager.

How can I get the installer to skip this task? What is the fix for this?

  • Are you trying to install Service pack or SQL Server ? Bit confused. If you are trying to install SQL Server did you made sure Cluster validation report has no error. What account you are using is it added as local admin on both nodes. Does it has rights to query AD ? – Shanky Nov 18 '14 at 19:14
  • This is a SQL Server install. The cluster validation report has no errors. I'm logged into the node using the sql service account that will be running the services when it is installed. The account is a local admin on the box. I'm unsure about the AD query rights. – Geoff Dawdy Nov 18 '14 at 19:31
  • Can you take account which is domain administrator and first add this account as local admin on both nodes then log into one of the node using this domain admin account and try then right click on setup and select run as administrator. Tell me what happens then – Shanky Nov 18 '14 at 19:33
  • I don't have domain admin rights. Shouldn't I be able to get this working without resorting to being a domain admin? – Geoff Dawdy Nov 18 '14 at 19:48
  • Its able to run discovery on local node but not on other node I am not sure, but with my exp it mostly due to permission issue or something to do with AD and authentication. To avoid all such things I asked you to give it a try using Domain admin account – Shanky Nov 18 '14 at 20:04
1

The install is no longer hanging. After opening a call with Microsoft we discovered the problem was trying to open the registry of the other node on the cluster. Additionally we were unable to use admin shares (i.e. \NODE1\C$). Once we enabled the Admin Shares, I was able to perform the installation and get past the point where it was hanging.

  • Enable Admin Shares (i.e. \NODE1\C$ should be accessible from NODE2)
  • So was it related to account issue ? Did account had no permissions on the folder. Can you make your answer more clear giving more explanations it would really help others users. – Shanky Nov 19 '14 at 18:43
  • I added a bullet point for the fix. Hope that helps. – Geoff Dawdy Nov 20 '14 at 16:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.