1

I have MySQL Server 5.6 installed in a development machine with these specs:

RAM: 4 GB Windows 7 Professional 64 bits Intel Pentium CPU G630 @ 2.70 GHZ

Since I installed the MySQL Server, the process mysqld.exe is consumpting 433 MB.

What I want to achieve is to reduce this consumption as much as possible.

What I have tried

I read some posts about adding some parameters to the my.ini, but inside the MySQL directory I have a file called my-default.ini so I added the following properties inside:

[mysqld]

# join_buffer_size = 128M
# sort_buffer_size = 2M
# read_rnd_buffer_size = 2M 
innodb_buffer_pool_size=5M
innodb_log_buffer_size=256K
query_cache_size=0
max_connections=10
key_buffer_size=8
thread_cache_size=0
host_cache_size=0
innodb_ft_cache_size=1600000
innodb_ft_total_cache_size=32000000

# per thread or per operation settings
thread_stack=131072
sort_buffer_size=32K
read_buffer_size=8200
read_rnd_buffer_size=8200
max_heap_table_size=16K
tmp_table_size=1K
bulk_insert_buffer_size=0
join_buffer_size=128
net_buffer_length=1K
innodb_sort_buffer_size=64K

#settings that relate to the binary log (if enabled)
binlog_cache_size=4K
binlog_stmt_cache_size=4K
performance_schema = off

Also I ran these commands to flush the queries cache:

FLUSH QUERY CACHE;
RESET QUERY CACHE;

All these attempts have not reduced an Megabyte, it stills consumption 433 MB.

Thanks in advance

1

Which version are you using? 5.6.?

I did however came across this bug, hopefully it helps.

http://bugs.mysql.com/bug.php?id=68287

  • Following the comments from your link, I updated to the most recent MySQL Server version 5.6.21 and the memory remains in 433 MB. Do you think is a unsolved bug? – Jessai Nov 19 '14 at 16:58
  • There are a lot of variables to take into consideration for optimization. Here is a suggestion, open an account on AWS and set up a couple of EC2-Instances to test your theory OR set up an RDS based on your needs. – JPorTer Apr 17 '15 at 20:56
0

I had the same problem with my MySql 5.6.10 version, and the following helped me.

Try adding the following in your my.ini (or my.cnf) file under the [mysqld] part:

table_definition_cache = 400
performance_schema=0

and restart your mysql server. In my case after doing the above my mysql server's RAM usage went down from ~430MB to ~20 MB.

You can read more about the issue in detail here.

I hope this helps someone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.