5

below is the error

Status : Failure -Io exception: The Network Adapter could not establish the connection

It's connecting from my system but unable to connect from other systems on the network. ping command is working fine and tnsping is also working. any suggestion and help is very helpful.

problem resolved thanks for the support..It wasn't the database fault...It was an network issue....

10
  • can you please provide me with sqlnet.ora as well as listener.ora Dec 22, 2014 at 12:16
  • # sqlnet.ora Network Configuration File: D:\app\Administrator\product\11.2.0\dbhome_1\network\admin\sqlnet.ora # Generated by Oracle configuration tools. # This file is actually generated by netca. But if customers choose to # install "Software Only", this file wont exist and without the native # authentication, they will not be able to connect to the database on NT. SQLNET.AUTHENTICATION_SERVICES= (NTS) NAMES.DIRECTORY_PATH= (TNSNAMES, EZCONNECT)
    – konark
    Dec 23, 2014 at 6:30
  • # listener.ora SID_LIST_LISTENER = (SID_LIST = (SID_DESC = (SID_NAME = CLRExtProc) (ORACLE_HOME = D:\app\Administrator\product\11.2.0\dbhome_1) (PROGRAM = extproc) (ENVS = "EXTPROC_DLLS=ONLY:D:\app\Administrator\product\11.2.0\dbhome_1\bin\oraclr11.dll") ) ) LISTENER = (DESCRIPTION_LIST = (DESCRIPTION = (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1521)) (ADDRESS = (PROTOCOL = TCP)(HOST = KONARK-PC)(PORT = 1521)) ) )
    – konark
    Dec 23, 2014 at 6:32
  • add the following parameter "tcp.validnode_checking = no" or "TCP.EXCLUDED_NODES= (ip1,ip2,...)" to sqlnet.ora and restart the listener Dec 23, 2014 at 7:52
  • I have added "tcp.validnode_checking = no" to my sqlnet.ora and restarted the listener. But stll its not connecting
    – konark
    Dec 23, 2014 at 7:55

6 Answers 6

2

This seems to be a hostname resolution problem. Please try to connect to the IP address instead of the hostname.

If this is not the solution could you please post the output of the following command:

lsnrctl status

EDIT 1:

LISTENER = 
(DESCRIPTION_LIST = 
  (DESCRIPTION = 
    (ADDRESS = 
      (PROTOCOL = IPC)(KEY = EXTPROC1521)
    )
    (ADDRESS = 
      (PROTOCOL = TCP)(HOST = 192.168.2.64)(PORT = 1521)
    )
  )
)

EDIT 2:

It turned out to be an firewall problem. See comments below.

1
  • Comments are not for extended discussion; this conversation has been moved to chat.
    – Paul White
    Aug 29, 2017 at 9:28
0

I also have experienced it, often one issue is with the firewall, and it turns out there are 3 firewall on windows that domain, private, and public firewall, of the three types domain firewall I was still on, and after I shut down, I can make a connection well.

you can search windows firewall with advanced security on start menu.

0

I solved the problem by disabling IPv6

Edited the file

C:\oracleexe\app\oracle\product\11.2.0\server\network\ADMIN\listener.ora

and add (IP=V4_ONLY)

...
LISTENER =
  (DESCRIPTION_LIST =
    (DESCRIPTION =
      (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1))
      (ADDRESS = (PROTOCOL = TCP)(HOST = 0.0.0.0)(PORT = 1521)(IP=V4_ONLY))
    )
  )    
...
0

Try resetting your winsock settings by running

C:\> netsh winsock reset 

...in your command prompt. Make sure you run as an admin.

Reload your listener after restarting your winsock settings by typing the following command

C:\> lsnrctl reload 

...in your command prompt. This should help you find the right IP to configure your SQL Developer.

-1

To solve this problem: click on the ORCL in "Databases Detected" tab under Database Connection on the welcome page. You will then see a copy of ORCL as ORCL1 under Connection window on the left hand of SQL Developer User Interface. Click on the green plus sign button on the left to start a new connection. A new connection window will appear. Don't change the connection name but change the username to the username you use for your oracle database and enter your password. you can now connect the database. It should work.

-4

If you are done with all above solutions, Please run Sqldeveloper as "Run As administrator" and test

Imran Barolia

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.