2

A few months back I installed SQL Server 2008R2. At the time of installation I used

1.Mixed Authentication
2.NT Authority\NetworkService as the SQL Agent user name, and the same user name for all other components also.

At that time everything worked. Now when I start the Agent I am getting this below error.

Windows could not start the SQL Server Agent (MSSQLSERVER) service on Local Computer. Error 1053: The service did not respond to the start or control request in a timely fashion.

I followed this link (http://support.microsoft.com/kb/322140). The steps are not clear to me but I tried a few. When I run by using cmd as admin I get this error:

The program can't start because sqlncli10.dll is missing from your computer. Try reinstalling the program to fix this problem.

Please can anyone help me with easy steps?

  • Try doing a repair installation from the 2008R2 setup.exe. – LowlyDBA Dec 30 '14 at 15:19
1

I have seen such problems when other VS is installed\updated after installing SQL server. Easy step will be to run SQL repair - Steps here.

Alternative solution is to install SQL Native client and can be downloaded from here under install instructions.

Again, above solution will only solve current error. It will be great if you could share more information like when it got corrupt and what was installed to provide you better solution.

0

We believe this was an out-of-sync issue w/ SQL Server 2017 components.

We had installed SQL Server 2017 Standard edition w/ CU16. then 2 months later, we reran setup.exe and selected the components 'R' and 'Python'.

We immediately encountered an error trying to start the 'SQL Server Launchpad (MSSQLSERVER)' service on our SQL Server:

1053 The Service did not respond to the start or control request in a timely fashion

Several resolution attempts failed UNTIL I downloaded and installed SQL Server 2017 CU17. One of the GOOGLE hits I read mentioned if you install SQL Server 2017 1st and then, at a later date, install R Services and Python, you may encounter an out of sync issue. To resolve, install the latest CU which should act on all SQL Server components and sync them up.

This worked for us.

New contributor
user192885 is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.