0

I'm trying to connect from my computer to a server which has a SQL Server 2008 instance installed. My computer and the server are in the same domain and the name of the server is "SERVER". The instance name is "SZSQL". If I try to connect on the server in SQL Management Studio 2008 I'm able to login using instance SERVER\SZSQL, user sa and the admin password. When I try using these login data in MS Visual Studio 2012 Server-Explorer, I get an error (translation below):

enter image description here

In English:

A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: SQL Network Interfaces, error: 26 - Error Locating Server/Instance Specified).

Like I told you before, the instance name, username and password are correct when I try to login on the server itself. Just the connection from my computer to the server is not working.

Any suggestions? :)

EDIT: The Server is running on Windows Server 2008 Standard

2
  • Well your screenshot does not show you have selected a database. What happens if you select one?
    – user507
    Jan 1 '15 at 15:30
  • Thats the problem. Normally there should be all databases. But if I open the dropdownlist, it loads a few seconds and then throws this error. I cannot even select a database because there isn't listed any databases.
    – Tyler
    Jan 1 '15 at 15:35
2

Have you turned on TCP/IP access in the SQL configuration manager? It's off by default for security reasons and is the first thing you have to turn on for remote DB access.

You will also need to open port 1433 in the firewall and in the case of a non-default instance, port 1434 as well. For non-default instances, the SQL Server Browser service must also be running.

14
  • Hi and thank you for your answer. If I turn it on, I have to restart the service. But what service? The service called SQL Server (SZSQL) in services.msc? Or what service?
    – Tyler
    Jan 1 '15 at 16:30
  • Yes, that's the one.
    – James
    Jan 1 '15 at 16:33
  • Hmm, I did it but it didn't change anything. Am I supposed to change the settings on TCP/IP?
    – Tyler
    Jan 1 '15 at 16:36
  • You may need to poke a hole in the firewall as well. Turn it off completely to test to see if that is the issue.
    – James
    Jan 1 '15 at 16:38
  • Thats what I thought first but it isn't the reason. Nothing changed when I turn it off
    – Tyler
    Jan 1 '15 at 16:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.