2

I have tried everything to be able to connect to my MS SQL Server 2012 remotely.
I have read and setup everything like Kyralessa wrote in his answer HERE.

  • Enable TCP/IP done
  • Add 1433 TCP Port done
  • enable SQL Server Browser done
  • Add 1433 TCP, 1434 UDP ports to Windows Firewall done
  • Add sqlserver.exe and sqlbrowser.exe to Windows Firewall done
  • Use ip address and port to connect done

I am still receiving an error message: Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: TCP Provider, error: 0 - A connection attampt failed because the connected party did not properly respond after a period of time.

Nothing works
Do you maybe have any other solution I could try to solve this problem?

migrated from stackoverflow.com Jan 4 '15 at 0:21

This question came from our site for professional and enthusiast programmers.

  • You granted yourself access to be able to access your own database correct? – WhyCry Dec 22 '14 at 20:48
  • @WhyCry Granted? Where? – Nidzaaaa Dec 22 '14 at 20:49
  • Ignore that previous comment, do you have the error message that appears when you try to connect? – WhyCry Dec 22 '14 at 20:53
  • @WhyCry Yes, I just updated my question with error message. – Nidzaaaa Dec 22 '14 at 20:56
  • You also went to the server properties of your database/server and allowed remote connections? – WhyCry Dec 22 '14 at 21:00
1

I have solved this problem with Port Forwarding.
I've seen no tutorial for Remote Access to SQL Server with this part.
So, setup 1433 TCP Port forwarding in your Router Settings and everything will work as it should.

  • Most database servers aren't behind residential-grade home network routers, that's why ;) – Dai Dec 23 '14 at 20:02
  • Well @Dai this is just for testing. I know I will have to improve security a lot if I want this to be a part of my company system (btw, do you have any tips on how to make my application more secure in vb.net/sql server, any links?) – Nidzaaaa Dec 23 '14 at 20:06
  • 1
    Respectfully I will not answer that question because it is too broad. – Dai Dec 23 '14 at 20:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.