1

Good day to all, Currently I have 4 as400 servers, with db2 installed, is the production server and development server with its two replicas.

The development java team uses IBM Toolbox for Java and JTOpen for conection to db2, in a Weblogic middleware, for direct connections to the database uses DbVisualizer with JTOpen (jt400.jar)

The team of RPG no has problem, at connect with IBM Access for Windows and work with DB2

Mysteriously on Sunday the development server connections began to be rejected for Java team

The error log is:

Long Message:
The application requester cannot establish the connection. (Not able to pass connection to server job. Server job program was not found.)

Details:
   Type: java.sql.SQLException
   Error Code: -99999
   SQL State: 08001

None of the other three servers has this problem. In this page of support recommend 3 possible solutions

  1. The system name is incorrect. One way to verify this is to use ping with the specified system name. If ping fails, then there is a TCP/IP configuration problem between your client and the system.
  2. The user ID or password is incorrect.
  3. The IBM i database host server is not started. You can start this by running STRHOSTSVR *DATABASE on the IBM i command line. You can verify if the IBM i database host server is running using the utilities.JPing application.

In step one send a ping to the server and it responds correctly in all machines of java team The step 2 was extensively tested, and 3 was able be verified, RPG dev team was not problem

A test was made more with an ODBC client and the connection was rejected also with this error log

Error in the connection test in initializing provider CWBSY1008

There was an error overall security rc=8007

I tried to find solution, but I have not found anything.

Other things I made

  1. IPL Partial and Full - Result not work
  2. Resetting router tables - Result not work
  3. Power off firewall and antivirus - Result not work
  4. Resetting password of QUSER - Result not work

Could you please help?

1

As I understand it, your development team got the error when using DbVisualizer with JTOpen (jt400.jar) for direct connections to the database.

I got the same exception with DBvis ver 9.1.10. The tool took a long time when clicking the connect button, then finally showed error code -99999.

What I do to fix this is to disable the Proxy setting of DBvis:

  1. Menu: Tool/Tool Properties
  2. Go to General Tag->Proxy Setting
  3. Check "No Proxy" and restart DBvisualizer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.