0

I recently installed RapidMiner and tried connecting the application to my MS SQL database connection via the Manage Database Connections feature. I have followed video tutorials on integrating SQL Server but i keep getting errors on connecting to localhost, and port 1433.

I have checked to see if SQL Server browser was running. It is. My TCP/IP connection is enabled, and also my default port is 1433. So what can be the problem?

I use mixed authentication with SQL Management Studio, i added the same in the Manage DB Connection form. But i keep getting an error:

"The TCP/IP connection to the localhost, port 1433 has failed. Error: Conection refused. connect"

I tried using Microsoft SQL Server (JTDS) as DB system (I downloaded JTDS from Sourceforge), but i keep getting a

"Network error IOException: Connection refused:connect"

Please, I'd really appreciate help because it's left me frustrated as i need this application to work for some project i am undertaking.

Thanks

  • Are you able to connect to the database directly through Management Studio using the same login? – LowlyDBA Jan 6 '15 at 13:44
  • Yes i am. I don't have any issues logging into SQL Management Studio – gbade_ Jan 6 '15 at 14:12
  • If using kerberos/integratedSecurity, your JTDS URL should look like: jdbc:jtds:sqlserver://hostname/dbname;domain=$domain;user=$username;password=$password – Neil McGuigan Sep 7 '16 at 16:31
0

Check if TCP-IP is enabled with SQL Server Configuration Manager. Run SQL Server Configuration Manager for different versions of SQL.

Then Edit TCP-IP and go to IPAll and set TCP-IP port to 1433 and Dynamic port to 0, then restart SQL Server service.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.