2

I currently have an instance of SQL running as NETWORK SERVICE which for various reasons I can't change.

I have a maintenance plan running under a proxy account which has access to a network share to write backup files. The proxy is set to run SSIS and cmdExec commands which are enabled on the server also.

If I run the job I get an error as below:

 Executed as user: xx\proxyaccount   Executing query "DECLARE @Guid UNIQUEIDENTIFIER      EXECUTE msdb..sp...".: 100% complete  End Progress  Error: 2015-01-14 10:44:23.24     Code: 0xC002F210     Source: Back Up Database (Full) Execute SQL Task     Description: Executing the query "EXECUTE master.dbo.xp_create_subdir N'\\share..." failed with the following error: "xp_create_subdir() returned error 183, 'Cannot create a file when that file already exists.'". Possible failure reasons: Problems with the query, "ResultSet" property not set correctly, parameters not set correctly, or connection not established correctly.  End Error  Error: 2015-01-14 10:44:23.54     Code: 0xC002F210     Source: Back Up Database (Full) Execute SQL Task     Description: Executing the query "BACKUP DATABASE [master] TO  DISK = N'\\share..." failed with the following error: "Cannot open backup device '\\share\xxx\master\master.bak'. Operating system error 5(Access is denied.).

The file definitely does not exist and so I think this is a bogus message, and the account definitely has access as I can map to the share and write files using it. I suspect the proxy account is not functioning correctly and is trying to use NETWORK SERVICE even though it claims its trying to run the job as the proxy account at the start of the message.

Does anyone know if proxy accounts don't work if running SQL as a local account?


I have since added the compute account to the share and it works. However for me this seems to be completely missing the point that it should run as the proxy account :s


Some more info. I have recreated the problem on my local machine, and changed it from NETWORK SERVICE to a domain account and still get the issue. If I grant the SQL Service account access then it works. However why isn't it running as the proxy account? I notice that the command being run is a xp_create_subdir, can you not run these as a proxy account?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.