2

We're running SQLServer 2005 SP1 and for some weird reason our one database transaction log automatically changed it's Autogrowth to 12800% which isn't even a valid number. I cannot change the growth % because of the invalid number.

I've scoured the Internet and saw a lot of other people also had this problem but with no clear solutions.

What caused this to happen and how can I fix it?

4
  • Seems I've asked to quickly I've found the solution support.microsoft.com/kb/919611
    – fluf
    Dec 8, 2011 at 11:08
  • Please post your comment as an answer and then mark it as such, or edit your question and mark it closed. It helps improve the site knowing the question has an answer for those searching for the same issue you experienced.
    – user507
    Dec 8, 2011 at 14:53
  • @ShawnMelton I was planning to :) I just have to wait 2 more hours before I can answer my own question
    – fluf
    Dec 8, 2011 at 16:25
  • sorry, I always forget about that 2 hr limit
    – user507
    Dec 8, 2011 at 16:38

2 Answers 2

3

Unfortunately it's a bug.

You can find all the affected databases by looking in sys.master_files. Write ALTER DATABASE scripts to change it.

0
2

As I discovered a few seconds after I posted the question it is a known bug : support.microsoft.com/kb/919611

The simplest solution is to install the next service pack (I updated to SP4) after the restart it automatically changed the 12800% back to the previous setting which was 100MB increments.

1
  • mark this as an answer - good work
    – VDMT
    Dec 10, 2011 at 7:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.