0

In our SSRS report manager page we get the below error on the Datasources. This all worked fine previously and seems to suddenly have stopped working. I have no idea what the issue could be.

All SPN are set up and the rsreportserver config file contains correct authentication...

    <AuthenticationTypes>
        <RSWindowsNegotiate/>
        <RSWindowsKerberos/>
        <RSWindowsNTLM/>
    </AuthenticationTypes>

enter image description here

In the SQL Server logs I see this error...

Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'. Reason: Token-based server access validation failed with an infrastructure error.

I followed the checklist listed here for SPN - http://blogs.technet.com/b/taraj/archive/2009/01/29/checklist-for-double-hop-issues-iis-and-sql-server.aspx but still not fixed the issue.

What is causing this issue??

2
  • Looks like the SQL Server service was running as 'Local System' rather than the service account. I changed this and works now! So it seems that the SQL Service defaulted to run as 'Local System' when it restarted. Any ideas why this might be?
    – K09
    Jan 18, 2015 at 19:56
  • I would likely say someone changed it. It would not happen on its own.
    – user507
    Jan 19, 2015 at 1:22

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.