8

I recently upgraded my local SQL Server to Version 2014, which also installed the SSMS 2014.
When using SQL Server Management Studio 2014 to create a backup (both local and remote, Server Versions 2008 - 2014), I get the following error:

To accomplish this action, set property Devices.

In the dropdown I chose Disk and I've also chosen a path for the backup. The path exists on the server and I've got full permission on this path.
If I use the old SQL Server Management Studio 2012 with the same settings, the backup works without any issues.
It also works using T-SQL BACKUP DATABASE SOMEDATABASE TO DISK = 'D:\SomeDir\SomeDataBase.bak' WITH COMPRESSION

So the issue has to be specific with the Management Tools Version 2014. The only solutions I found on the internet were due to missing path, which isn't the case for me.
Has anyone experienced and/or solved this issue?

Edit: Added Screenshot (UI in German)

Backup Error SSMS 2014

Translation:
- Vollständig: Full
- Datenträger: Disk

Media and security options unchanged. Master database was just taken as example, happens to every other database.

Media options Security options

Update 21.07.2015

The problem seems to be related to me using an English language pack on a German Windows and a German SQL Server 2014 installation. If the Windows display language is set to German, the issue disappears. If the Windows display language is set to English, the issue reappears.

Thanks for all contributions.

2

I fixed the same symptoms/issue (which surfaced after I reinstalled the Visual Studio 2010 Isolated Shell, on which SSMS depends as a component) by removing the 2010 Visal Studio Isolated Shell and then repairing SSMS 2014 (download SSMS 2014 SP1 from here):

Remove Visual Studio 2010 Isolated Shell

Repair SSMS Installation

  • I tried this out and it looked very promising at first, but the issue reappeared again. I also had to reinstall VS2010 Isolated Shell during the Repair process. But thanks to this I found out, that the issue is connected to me using an English language pack on a German Windows with a German SQL installation. As soon as I change the Windows display language back to German, the issue disappears. – Quant Jul 21 '15 at 15:31
  • @Quant Thank you! My issue is also solved by changing the Windows Display Language! – yu yang Jian Aug 10 '18 at 2:46
4

Here is my Answer for Error message "To accomplish this action, set property Devices. (Microsoft.SqlServer.SmoExtended)"

  1. Make sure the User Account you are logged in as has DBO rights on both, the MASTER Db and the DB you want to backup.

  2. Using the SQL Express Manager, Expand the SQL Server Objects in the left pane and find "Server Objects" then click on "Backup Devices"

Right Click and create a "New BackUp Device.." and call it the same as the DB to be backed up... pointing to a directory on your server (e.g.: C:\MySQLBackups...)

This will create an "empty file" with the .bak extention. (e.g. C:\MySQLBackups\DatabaseName.bak)

Then right-click on this new device created and select "Backup database"...

The rest is straight forward...

This worked for me... Good luck!"

0

I could be wrong, (especially since I don't know German) but looking at the options on the second screen (Media Options), did you try doing "back up to a new media set", instead of an existing one? In 2014 there are additional options. Since it is a 2012 database you are trying to back up, there are probably defaults set in those options which are incompatible.

  • 2012: General, Options
  • 2014: General, Media Options, and Backup Options.
  • It's set to "Back up to existing media set". Furthermore it's also happening with SQL2014 databases. – Quant Apr 21 '15 at 11:29
  • that's what I mean - try using a new media set, then begin using the existing one you just created – rottengeek Apr 21 '15 at 17:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.