Before Christmas I had no problem connecting SSMS 2008 R2 to a specific remote database. Since Christmas, I get this error when I try to connect:

TITLE: Connect to Server

Cannot connect to [IP ADDRESS].


An exception occurred while executing a Transact-SQL statement or batch. (Microsoft.SqlServer.ConnectionInfo)

A transport-level error has occurred when receiving results from the server. (provider: TCP Provider, error: 0 - The semaphore timeout period has expired.) (Microsoft SQL Server, Error: 121)

For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&EvtSrc=MSSQLServer&EvtID=121&LinkId=20476

Any idea why this is happening? The link provided in the error message gives no information at all.

As far as I know, no updates or changes have been made to SSMS 2008 R2 or the database since the happy time when I could connect and now.

Any help much appreciated.

  • Have you rebooted the server since Christmas?
    – user507
    Jan 23 '15 at 2:45
  • It's not my server. But other machines can connect to it. Just suddenly this one machine's SSMS cannot connect to this one particular server although it can connect to others. I don't know what could have changed.
    – craig2014
    Jan 23 '15 at 3:51
  • This is then a network problem from that one machine to the database server. You should have your network admin verify nothing changed or find why it is not connecting. Also based on the error you are executing a query, are you simply trying to connect in SSMS or in fact executing a command.
    – user507
    Jan 23 '15 at 4:01
  • 1
    Are you using plain server name, FQDN, or IP address? Are you on the same domain? Are you using SQL auth or Windows auth? What is different about the machine that can still connect? Are you seeing any errors in the error log? Did you try changing your login's default database? Did you check for logon triggers? Are you using Resource Governor? Were you on the nice list or the naughty list? Jan 23 '15 at 4:08
  • Just trying to connect using IP address. Nothing has been changed at all. Something must have become corrupted on the machine that is now keeping SSMS from connecting to this one particular server. Just tried the SQL Server Import and Export Wizard and it worked just fine. Something has gone weird with SSMS and this one particular server. Oh, well.
    – craig2014
    Jan 23 '15 at 18:39

Your first test should be to just try and connect via telnet to port 1433 of the ip in question (assuming it isn't a named instance in which case check the start of your SQL error log to get the dynamic port number). This will at least prove the server is listening correctly and you dont have any network/firewall issues.

  • Thanks. Connecting to port 1433 via Telnet was successful. Any other thoughts?
    – craig2014
    Jan 23 '15 at 1:55

Not the answer you're looking for? Browse other questions tagged or ask your own question.