0

Mysqld don't restart anymore...In the log, the apparently obvious reason:

mysqld started
[Warning] Ignoring user change to 'root' because the user was set to 'mysql' earlier on the command line
[ERROR] /usr/libexec/mysqld: unknown variable 'password=mypassword'
mysqld ended

/etc/my.cnf there is nothing relevant and there is no such variable, which by the way has the correct mysql root password value in the message (!!!?):

[mysqld]
user=mysql
datadir=/var/lib/mysql
socket=/var/lib/mysql/mysql.sock
[mysqld_safe] 
log-error=/var/log/mysqld.log
pid-file=/var/run/mysqld/mysqld.pid

Mysql 5.0.95 on Centos 5.9. It worked ok before restarting!!

Tried also

 /usr/bin/mysqld_safe --datadir=/var/lib/mysql --pid-file=/var/run/mysqld/mysqld.pid --no-defaults
Starting mysqld daemon with databases from /var/lib/mysql
STOPPING server from pid file /var/run/mysqld/mysqld.pid
mysqld ended
1
  • Something tells me --no-defaults needs to be the first option, though that may or may not be right. At any rate, mysqld --help --verbose | less should include a list of the various places it could be loading that file from. Jan 28 '15 at 1:10
0

I followed the last suggestion here

cd /usr
./mysqld_safe --defaults-file=/etc/my.cnf --user=mysql --ledir=/usr/libexec &

Now it started, but don't understand it...not very nice!!!

-1

I'v got same problem. Just deleted password line from /etc/my.conf and mysqld started Have no idea what was that...

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.