5

I have error in my log for a few weeks, I searched a lot but I couldn't found useful answer.

I did closed SQL Server port for public IP, but I have problem yet.

Error: 17806, Severity: 20, State: 14.
SSPI handshake failed with error code 0x8009030c, state 14 while establishing a connection with integrated security; the connection has been closed. Reason: AcceptSecurityContext failed. The Windows error code indicates the cause of failure. The logon attempt failed [CLIENT: 10.10.3.25]

Time raised: 27 Jan 2015 2:23 PM

It was raised error while this system was off.

4

Any time I have seen this error in my environment (0x8009030c and State 14), it has been because the SQL Server engine account was running with a Domain service account, and that account was locked at the time a Kerberos connection was attempted. The connection would work, but it would be kicked down to NTLM.

Method 1:

  1. Go to register start –> run … Regedit
  2. Go to: HKLM\System\CurrentControlSet\Control\LSA
  3. Add a DWORD value called “DisableLoopbackCheck”
  4. Set this value to 1
  5. Rebooted after making this change.

After this registry change was effected.

Method 2. This somehow worked for me: Restarting the sql browser services:

Also, for more info on the related issue, refer to below article:

http://www.allenkinsel.com/archive/2010/06/sql-server-and-sspi-handshake-failed-error-hell/

  • Can i refer this problem to my network admin? is this a network issue or a sql server issue. Is there any other way other then changing the registry ? Can i safely ignore this error ? – SqlNovice Nov 19 '17 at 23:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.