I am trying to Configure the Master target server / Multi server environment in Sql Server 2012.

I changed :

  • MSXENCryptChannnelOptions-->Changed from 2 to 0
  • AllowDownloadedJobsToMatchProxyName - changed from 0 to 1 on the target

When I run the wizard I am getting below error

MSX Enlist failed for Job Server 'MasterServerName'

The enlist operation Failed(Reason:SQL Server Agent Error: Unable to connect to MSX 'MasterServerName'(Microsoft Sql Server, Error : 22026)

They both servers SQL Agents are running on the same windows service account.

Any Suggestions on how to fix this?

Adding the Log:

Enlist TSX Progress

  • Create MSXOperator (Success) Checking for an existing MSXOperator.

Updating existing MSXOperator.

Successfully updated MSXOperator.

  • Make sure the Agent service for 'Test3' is running (Success) The service 'SQLSERVERAGENT' is running.

  • Ensure the agent startup account for 'Test4' has rights to login as a target server (Success)

Checking to see if the startup account for 'Test4' already exists.

Login exists on server.

Checking to see if login has rights to msdb.

Login has rights to msdb.

Checking to see if user is a member of the TargetServersRole.

User is a member of the TargetServersRole.

  • Enlist 'Test4' into 'Test3' (Error)

Enlisting target server 'Test4' with master server 'Test3'.

Using new enlistment method.


MSX enlist failed for JobServer 'Test4'. (Microsoft.SqlServer.Smo)


An exception occurred while executing a Transact-SQL statement or batch. (Microsoft.SqlServer.ConnectionInfo)

The enlist operation failed (reason: SQLServerAgent Error: Unable to connect to MSX 'TEST3'.) (Microsoft SQL Server, Error: 22026)

  • For MSXENCryptChannnelOptions, did you change that to 0 on the master, target, or both? It needs to be changed on the target. Also, if you are logged into Test4 as the MSXOperator, can you connect to Test3? Commented Feb 5, 2015 at 2:44
  • Hi Srutzky - I changed it on Both Master and Target 1st. After reading your comments I changed Master Encryption to 2 and tried to execute the wizard I got the same error as I was receiving before. Commented Feb 5, 2015 at 15:03

1 Answer 1


It is an old post and I assume you've fixed the issue by now but for people having same problem;

Check the Sql server configuration manager and make sure the TCP/IP protocol is enabled for master and target servers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.