0

I have an SSIS (2012) package which was written by one of the developers. I've been tasked to with fixing the error. Each time the package is run I receive the following three messages indicating the Write Output File [339] produced errors.

Transform File and create output file:Error: Write Output File failed the pre-execute phase and returned error code 0xC020200E

Transform File and create output file:Error: Cannot open the datafile "\\servershare\folder\file"

Transform File and create output file:Warning: Access is denied.

I have tried granting full control to the folder share to myself, the SQL Agent account, and the SQL Services account. Whether I run the package as myself or as a service account I receive the error messages.

I'm not seeing any more details in the SQL Server error logs or the Windows Event logs.

  • 2
    You may need to check the permissions on the folder itself, not just the shared permissions. It will need access through both places in Windows. – Shawn Melton Feb 7 '15 at 3:36
  • I just checked. The user has full control to the folder. – Geoff Dawdy Feb 8 '15 at 4:45
0

This ended up being a Kerberos problem. We were able to identify through some of the security logs and some network monitoring, that the request was coming in as anonymous. Once we applied the relevant SPNs for MSSQLSVC for the account that was being used to kick off the process, it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.