3

If I use raise notice, I get context messages at each execution. Can I turn them off and just get the NOTICE?

NOTICE:  d = [2,1] ,tn: (1,2,"{NULL,NULL}","{{-1,4},{-1,-1}}",1)
CONTEXT:  SQL statement "SELECT aPt( vl , tn_id, color )  from tnodes where tnode_id = tn_id"
PL/pgSQL function "apt" line 42 at PERFORM
SQL statement "select  aPt(vl, tn.chldrn[d[1]][d[2]], color) from tnodes where tnode_id = tn_id"
PL/pgSQL function "apt" line 46 at SQL statement
SQL statement "SELECT aPt('{0.5,1}',itVar,1)"
PL/pgSQL function "bi" line 16 at PERFORM

I'm using postgres 9.1.14, Thanks.

3
  • 2
    I think it's controlled by log_error_verbosity Try set log_error_verbosity=DEFAULT
    – user1822
    Feb 17, 2015 at 7:03
  • 5
    @a_horse_with_no_name's suggestion applies to the contents of the log file. For psql, the equivalent is \set VERBOSITY terse. Feb 17, 2015 at 14:56
  • Of note, VERBOSITY is case-sensitive.
    – Randall
    Apr 10, 2020 at 0:30

1 Answer 1

1

The solution : As write – dezso Feb 17 '15 at 14:56, using \set VERBOSITYE 'terse' is the right way.

I've to add this option in my scripts using psql :

psql --dbname=DB_production --VERBOSITY=terse

But, I can't understand why on others instances, servers, environments, I haven't to do this.

1
  • What does is the postgresql.conf log_error_verbosity value in those other environments?
    – RonJohn
    Jan 28, 2023 at 21:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.