I'm not able to connect to sql server with anything but on the server machine. If I try to connect via actual IP on the network it does not work locally or remotely.

The environment is SQL Server 2005 on Windows Server 2000. My goal is to connect to this SQL Server instance from a remote machine.

I've tried telneting to port 1433 using the actual IP and that fails. I've tried turning off Windows Firewall completely

Any ideas or help is greatly appreciated! Thanks

  • Have you checked tcp/ip is enabled in SQL server configuration manager? And that allow remote connections is enabled on the SQL server instance? – VDMT Dec 16 '11 at 21:11
  • Yes, tcp/ip is enabled and remote connections is enabled for tcp/ip only – Alex Dec 16 '11 at 21:49
  • can you ping the server machine from remote? (I assume you have turned off the firewall on the server at this point) what is the IP that your are connecting to via SSMS on remote machine? – VDMT Dec 16 '11 at 22:04
  • Yes I can ping it from the remote machine. I do have the firewall turned off on the server. The IP that I'm connecting to is – Alex Dec 16 '11 at 22:24
  • do a netstat -a on the server, make sure it's listening on port 1433. Then, if you can't telnet to 1433 from a remote host, something in your network is filtering it. – Simon Righarts Dec 17 '11 at 6:28

Are you running multiple instances?

Make sure that TCP connections are enabled.

Make sure a connection is allowed by your firewall, or that the firewall is disabled.

If you have trouble with either of these after making changes, try re-starting the DB and SQL Server Browser (or disable Browser).

| improve this answer | |
  • No, just the default instance. TCP connections are enabled. Firewall is turned off. I have tried restarting the DB and the SQL Server Browser is disabled. Still no luck :-/ – Alex Dec 19 '11 at 17:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.