0

I have given a description column datatype as NVARCHAR(MAX) but when I add the data it shows me only half data. Not full data. For Example:-

If I have two para like below:-

As the saying goes “Seeing is Believing”, based on this premise Aditya Jyot was founded in 2005 to illuminate the lives of the less privileged people suffering ailments related to visual impairment. The organisation aims at redressing the suffering of low income groups, marginalised population living in the rural and urban slums and tribal pockets through free eye camps and treatment.

The foundation in association with us (RBL Bank) aims at spreading awareness and implementing preventive healthcare services on Retinopathy in diabetic patients causing blindness through a well-equipped outreach centre in the urban slums of Dharavi, Mumbai touching about 6 lakh beneficiaries. Thus, contributing towards creating healthier communities

I will only see the data till Treatment. I am not able to see the data which is ahead. Please suggest

  • 1
    I would guess this is caused by your SQL client not displaying all the data. Which SQL client are you using? Maybe check the manual to see if there is a max. display length somewhere in the options. – a_horse_with_no_name Feb 18 '15 at 8:01
  • If there's line breaks / new lines there, that might also cause issues in the client side, if it just assumes it's a single text without separate lines – James Z Feb 18 '15 at 8:08
  • @a_horse_with_no_name: I am using SQL Server 2008 R2.Please help – B N Feb 18 '15 at 8:19
3

This is the default setting SQL Server Management Studio, Navigate on Menu button as follows

If you are using Result to Grid:

Tools --> Options --> Expand Query Results --> Expand SQL Server -- > select result to Grid

then at the right side you will see Maximum number of characters Retrieved and Non XML Data with the Text box, enter 65535(This is maximum possible value) then click on OK.

If you are using result to Text:

Tools --> Options --> Expand Query Results --> Expand SQL Server -- > select result to Text

then at the right side you will see Maximum number of characters displayed in each Column and the Text box, enter 8192 (This is maximum possible value) then click on OK.

Note: You need to open new Window for the changes to take effect, it will not be applicable for opened windows.

  • Thanks Ibrahim, that helped me. and it is working fine..!! – B N Feb 18 '15 at 12:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.