I am on Windows 8, my SSD got corrupted and I installed Windows on a new drive. I had before MySQL 5.6.12, now I installed 5.6.17 and tried to move the entire data dir. The location of the MySQL installation is the same as before. But when I start it I get the following error:

2015-02-23 17:44:44 12492 [Note] Plugin 'FEDERATED' is disabled.
wampmysqld64: Incorrect information in file: '.\mysql\plugin.frm'
2015-02-23 17:44:44 12492 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
2015-02-23 17:44:44 12492 [Note] InnoDB: Using atomics to ref count buffer pool pages
2015-02-23 17:44:44 12492 [Note] InnoDB: The InnoDB memory heap is disabled
2015-02-23 17:44:44 12492 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
2015-02-23 17:44:44 12492 [Note] InnoDB: Compressed tables use zlib 1.2.3
2015-02-23 17:44:44 12492 [Note] InnoDB: Not using CPU crc32 instructions
2015-02-23 17:44:44 12492 [Note] InnoDB: Initializing buffer pool, size = 128.0M
2015-02-23 17:44:45 12492 [Note] InnoDB: Completed initialization of buffer pool
2015-02-23 17:44:45 12492 [Note] InnoDB: Restoring page 0 of tablespace 0
2015-02-23 17:44:45 12492 [Warning] InnoDB: Doublewrite does not have page_no=0 of space: 0
2015-02-23 17:44:45 12492 [ERROR] InnoDB: space header page consists of zero bytes in data file .\ibdata1
2015-02-23 17:44:45 12492 [ERROR] InnoDB: Could not open or create the system tablespace. If you tried to add new data files to the system tablespace, and it failed here, you should now edit innodb_data_file_path in my.cnf back to what it was, and remove the new ibdata files InnoDB created in this failed attempt. InnoDB only wrote those files full of zeros, but did not yet use them in any way. But be careful: do not remove old data files which contain your precious data!
2015-02-23 17:44:45 12492 [ERROR] Plugin 'InnoDB' init function returned error.
2015-02-23 17:44:45 12492 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
2015-02-23 17:44:45 12492 [ERROR] Unknown/unsupported storage engine: InnoDB
2015-02-23 17:44:45 12492 [ERROR] Aborting

mysql_upgrade fails with FATAL ERROR: Upgrade failed

Thank you very much for your time.

  • 2
    The tablespace is corrupt, MySQL won't start with it. Do you have any backups?
    – akuzminsky
    Feb 23, 2015 at 18:08
  • @akuzminsky Unfortunately no. Feb 24, 2015 at 11:47

2 Answers 2


Before doing any attempts for recovery make sure to have backup of data files.

" tried to move the entire data dir."

make sure my.ini has correct paths.

Look at error that points at innodb_data_file_path.

Do confirm your ibdata file(s) are at right location.


Suggestion that may help you fix this issue:

1) take a backup from the data directory example copy data folder to data_old folder you may need it in-case something went wrong

2) take a backup from my.ini file

3) copy content of the default my.ini and past it inside the one you are using ( dont forget to edit basedir , datadir and port number OR edit the current one.

4) from the datadir remove ib_logfileX

5) try to start the service.

6) use the normal dump commend mysqldump -uroot -Pport -ppassword --all-databases>dump.sql

7) restore it into another SID.

8) run mysql_upgrade on the new SID

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.