If I issue a LIST EXPIRED command in RMAN, I see a list of files with expired status, that is, they exist in the catalogue, but not on the disk (verified by ls). After issuing CROSSCHECK and DELETE EXPIRED commands, I would expect LIST EXPIRED to return nothing... but they are all still here.

This may or may not be causing my backups to sporadically fail on ORA-19588. I have checked and am 100% certain that I am not running two RMANs at the same time. Any ideas? Target is 10g and catalogue is 11g.

  • Perhaps you should list the full commands as you are entering them. – Leigh Riffel Feb 11 '11 at 16:19

Doing a LIST EXPIRED ARCHIVELOG and then a DELETE EXPIRED ARCHIVELOG should cause a new LIST EXPIRED ARCHIVELOG to not show any entries in most situations. Here are a few situations that could cause this to not be the case.

  1. If FORCE is not specified on the delete command then it follows the archived log deletion policy which determines when archived redo log files are eligible for deletion.

  2. The deletion policy does not apply to foreign archived redo log files, which are logs received by a logical standby database for a LogMiner session.

These possibilities are from this documentation. If neither is applicable then perhaps you are running into a bug and should open an SR with support.

I assume you are running commands like this:

   list expired archivelog all;
   crosscheck archivelog all;
   delete expired archivelog all;
   list expired archivelog all;

Perhaps the LIST EXPIRED entries are for items not being deleted by the specific delete command you are doing. For example, a DELETE EXPIRED BACKUP will not delete expired archivelogs or expired copies.

Since the problem is sporadic, you shouldn't be having the problem referenced in MOS Doc ID 1189883.1 in which the backup command follows the form backup archivelog all archivelog...

  • Nope, definitely specifying archive log for both. – Gaius Jan 27 '11 at 23:46
  • Have you tried specifying FORCE on the delete? – Leigh Riffel Feb 11 '11 at 16:20
  • Yep. I have a TAR open now, so the race is on between Stack Exchange and Metalink... – Gaius Feb 14 '11 at 15:17
  • 1
    I'd be surprised if either solved your problem before the bounty ends. This site due to the small user base and Oracle support because they are just that good. – Leigh Riffel Feb 14 '11 at 16:32

We have been running into the same problem, as original answer mentioned, for us issue was the FORCE option. Didn't realize that otherwise, retention policy is still used.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.