0

In my testing, I've found that the write_request_timeout_in_ms setting does not have any bearing on the timeouts for CREATE TABLE or ALTER TABLE statements in CQL. For instance, I have it set to 10000ms but I've found that some CREATE TABLE statements can take around 12 seconds to complete. So what's the correct setting?

0

According to a Datastax representative, the setting which affects schema changes is request_timeout_in_ms.

It should be noted that these timeout settings are not hard timeouts from the time your client application connects to the coordinator node. If the connection is lost, then the timeout counter restarts. Hence why I was seeing some CREATE TABLE commands taking 12 seconds even though I had request_timeout_in_ms set to 10000ms.

  • 1
    @John I'm actually going to wait until I get more clarification from them because I'm not sure they're right. I posted this then quickly realized their answer didn't make sense. – 2rs2ts Mar 9 '15 at 20:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.