2

I have a problem with a SPFILE as shown below.How can I get rid of that problem?Any suggestions?

 SQL> startup
 ORA-32004: obsolete or deprecated parameter(s) specified for RDBMS instance
 ORACLE instance started.

 Total System Global Area 1068937216 bytes
 Fixed Size                  2182592 bytes
 Variable Size             784335424 bytes
 Database Buffers          276824064 bytes
 Redo Buffers                5595136 bytes
 Database mounted.
 Database opened.
 SQL> alter system reset log_archive_start scope=spfile sid='*';
 alter system reset log_archive_start scope=spfile sid='*'
 *
 ERROR at line 1:
 ORA-32010: cannot find entry to delete in SPFILE
  • 3
    how did you identify that that was the obsolete parameter? IIRC the obsolete and deprecated parameters are listed in the alert.log at startup. – Niall Litchfield Dec 20 '11 at 13:52
1

Well, you can hack around with an SPFILE easily enough:

SQL> create pfile='/tmp/initSID.ora' from spfile;

Now edit that ordinary text file, then

SQL> create spfile from pfile='/tmp/initSID.ora';

And you can play with the temporary one with

SQL> startup pfile='/tmp/initSID.ora';

Note tho' there is no actual problem with specifying obsolete parameters other than the message; the only issue is if you were relying on them to set some desired behavior, and they were ignored.

0

ORA-32004: obsolete or deprecated parameter(s) specified for RDBMS instance

this error mainly occurs when you have used a parameter or changed the dynamic parameter which is not anymore used in that current version of oracle. In my case, I change the background_dump_dest location and gave the scope spfile so this parameter is not used in oracle 11g so what is did is

1)shut immediate the database

2)startup pfile = '/u01/app/oracle/product/11.2.0/dbhome_1/dbs/initorcl.ora'

3)Now create spfile from pfile='/u01/app/oracle/product/11.2.0/dbhome_1/dbs/initorcl.ora'

4)file created

5)now shut immediate

6)startup

you wont get that error again.

I hope this will help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.