0

What are the connection parameters? How do I confirm each value?

Workbench error:

Lost connection to MySQL server at 'reading initial communication packet', system error: 0

I can easily connect from doge to tleilax as so:

thufir@doge:~$ 
thufir@doge:~$ ssh thufir@192.168.1.3
Last login: Sat Mar  7 19:55:22 2015 from 192.168.1.2
Thank you for installing ViciBox Server v.6.0!
This software is available for free download at
http://www.vicibox.com. If you paid for this 
software you have been ripped off. Please report
any fraud or abuses of this software to 
abuse@vicidial.com. Please report any bugs on 
the forum at http://www.vicidial.org

To configure the LAN settings type:
yast lan

To change the server IP in the database type:
/usr/share/astguiclient/ADMIN_update_server_ip.pl

Official paid-for ViciDial support is available at 
http://www.vicidial.com

Free community-based ViciDial Support is available
at http://www.vicidial.org/VICIDIALforum

- ViciBox Redux v.6.0.3-141118
thufir@tleilax:~> 
thufir@tleilax:~> mysql -u cron -p
Enter password: 
Welcome to the MariaDB monitor.  Commands end with ; or \g.
Your MariaDB connection id is 572
Server version: 5.5.33-MariaDB-log openSUSE package

Copyright (c) 2000, 2013, Oracle, Monty Program Ab and others.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

MariaDB [(none)]> 
MariaDB [(none)]> exit
Bye
thufir@tleilax:~> exit
logout
Connection to 192.168.1.3 closed.
thufir@doge:~$ 
thufir@doge:~$ mysql -u cron -h 192.168.1.3 -p
Enter password: 

^C
thufir@doge:~$ 

Of course, I cannot login without using ssh.

Screenshot:

ssh

How can I check that the SSH password, and other parameters, are correct?

------------------------------------------------update, logs etc-------------

thufir@doge:~$ 
thufir@doge:~$ tree .mysql/
.mysql/
└── workbench
    ├── cache
    │   ├── doge.cache
    │   └── Local_instance_3306.cache
    ├── connections.xml
    ├── libraries
    ├── log
    │   ├── sql_actions_Local_instance_3306.log
    │   ├── sql_actions_tleilax.log
    │   ├── wb.1.log
    │   ├── wb.2.log
    │   ├── wb.3.log
    │   ├── wb.4.log
    │   ├── wb.5.log
    │   ├── wb.6.log
    │   ├── wb.7.log
    │   ├── wb.8.log
    │   ├── wb.9.log
    │   └── wb.log
    ├── modules
    ├── scripts
    ├── server_instances.xml
    ├── shell_bookmarks.txt
    ├── shell_history.txt
    ├── snippets
    │   ├── DB_Management.txt
    │   ├── SQL_DDL_Statements.txt
    │   └── SQL_DML_Statements.txt
    ├── sql_history
    │   └── 2015-02-23
    ├── sql_workspaces
    │   └── Local_instance_3306-1.autosave
    │       ├── 1.scratch
    │       ├── connection_id
    │       ├── contacts.scratch
    │       ├── lock
    │       └── new_table.scratch
    ├── starters_settings.xml
    ├── user_starters.xml
    ├── wb_options.xml
    └── wb_state.xml

10 directories, 31 files
thufir@doge:~$ 
thufir@doge:~$ cat .mysql/workbench/connections.xml 
<?xml version="1.0"?>
<data grt_format="2.0">
  <value _ptr_="0x3234e40" type="list" content-type="object" content-struct-name="db.mgmt.Connection">
    <value type="object" struct-name="db.mgmt.Connection" id="7d9dc778-baf8-11e4-a601-50e549c2c805" struct-checksum="0x96ba47d8">
      <link type="object" struct-name="db.mgmt.Driver" key="driver">com.mysql.rdbms.mysql.driver.native</link>
      <value type="string" key="hostIdentifier">Mysql@localhost:3306</value>
      <value type="int" key="isDefault">0</value>
      <value _ptr_="0x32c1860" type="dict" key="modules"/>
      <value _ptr_="0x341b860" type="dict" key="parameterValues">
        <value type="string" key="hostName">localhost</value>
        <value type="int" key="lastConnected">1424826826</value>
        <value type="int" key="port">3306</value>
        <value type="string" key="serverVersion">5.5.41-0ubuntu0.14.10.1</value>
        <value type="string" key="userName">root</value>
      </value>
      <value type="string" key="name">doge</value>
      <link type="object" struct-name="GrtObject" key="owner">0042c161-c549-11e4-912d-50e549c2c805</link>
    </value>
    <value type="object" struct-name="db.mgmt.Connection" id="502f6b25-bb54-11e4-a601-50e549c2c805" struct-checksum="0x96ba47d8">
      <link type="object" struct-name="db.mgmt.Driver" key="driver">com.mysql.rdbms.mysql.driver.native_sshtun</link>
      <value type="string" key="hostIdentifier">Mysql@tleilax:3306@192.168.1.3:22</value>
      <value type="int" key="isDefault">1</value>
      <value _ptr_="0x3430fe0" type="dict" key="modules"/>
      <value _ptr_="0x3431050" type="dict" key="parameterValues">
        <value type="string" key="SQL_MODE"></value>
        <value type="string" key="hostName">tleilax</value>
        <value type="string" key="password"></value>
        <value type="int" key="port">3306</value>
        <value type="string" key="schema"></value>
        <value type="string" key="sshHost">192.168.1.3:22</value>
        <value type="string" key="sshKeyFile">/home/thufir/.ssh/id_rsa</value>
        <value type="string" key="sshPassword"></value>
        <value type="string" key="sshUserName">thufir</value>
        <value type="string" key="sslCA"></value>
        <value type="string" key="sslCert"></value>
        <value type="string" key="sslCipher"></value>
        <value type="string" key="sslKey"></value>
        <value type="string" key="userName">cron</value>
      </value>
      <value type="string" key="name">tleilax</value>
      <link type="object" struct-name="GrtObject" key="owner">0042c161-c549-11e4-912d-50e549c2c805</link>
    </value>
  </value>
</data>
thufir@doge:~$ 
thufir@doge:~$ cat .mysql/workbench/log/wb.log 
20:09:47 [INF][      WBContext]: Parsing application arguments.
20:09:47 [INF][      WBContext]:     /usr/lib/mysql-workbench/mysql-workbench-bin
20:09:49 [INF][   WBContext UI]: Initializing workbench context UI with these values:
    base dir: /usr/share/mysql-workbench
    plugin path: /usr/lib/mysql-workbench/plugins
    struct path: /usr/share/mysql-workbench/grt
    module path: /usr/lib/mysql-workbench/modules
    library path: /usr/share/mysql-workbench/libraries
    user data dir: /home/thufir/.mysql/workbench
    open at start: 
    open type: 
    run at startup: 
    run type: 
    Force SW rendering: No
    Force OpenGL: No
    quit when done: No
20:09:49 [INF][      WBContext]: WbContext::init
20:10:03 [INF][            WBA]: Looking for extension modules for WBA...
20:10:03 [INF][            WBA]: 0 extension modules found
20:10:08 [WRN][            grt]: /home/thufir/.mysql/workbench/connections.xml:17: link 'e4bd839b-c547-11e4-b945-50e549c2c805' <object GrtObject> key=owner could not be resolved
20:10:08 [INF][      WBContext]: System info:
    MySQL Workbench Community (GPL) for Linux/Unix version 6.1.7  revision 11891 build 1788
    Configuration Directory: /home/thufir/.mysql/workbench
    Data Directory: /usr/share/mysql-workbench
    Cairo Version: 1.13.1
    OS: Linux 3.16.0-23-generic
    CPU: 6x AMD Phenom(tm) II X6 1090T Processor (800.000MHz) - 7.80GiB RAM
    Distribution: Ubuntu 14.10


20:10:09 [INF][    WQE backend]: Found auto-save workspace /home/thufir/.mysql/workbench/sql_workspaces/Local_instance_3306-1.autosave
thufir@doge:~$ 
  • 1
    if you are able to first ssh and then connect using the same parameters provided in workbench, you should be good. Please check for iptables/firewall/security related settings. the following may help stackoverflow.com/questions/5755819/… – Nawaz Sohail Mar 8 '15 at 15:57
  • It's almost certainly the connection parameters or how MySQL is configured. On the same network, I've been able to connect. Actually, that wasn't with SSL, just logged in as a user.. – Thufir Mar 8 '15 at 20:14
  • 1
    Try to find workbench log files. I don't use windows so I cannot help with the file location. You can search for wb.log and see what there is in. Eventually you could update your question with log file contents. – Giovanni Mar 9 '15 at 9:53
  • @Giovanni done. you're a genius. I dunno why, I guess the GUI mesmerized me, I never even thought to even look for a log.. – Thufir Mar 9 '15 at 14:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.