2

I am getting "Unknown table engine 'innodb'" for some query after changing my my.cnf. I have reverted the old my.cnf and restarted mysql and now I can see innodb.

Could you please help me figure out which parameter caused issue and why?

Original my.cnf::

[mysqld]
local-infile=0
datadir=/var/lib/mysql
socket=/var/lib/mysql/mysql.sock
user=mysql
open_files_limit = 100000
# Disabling symbolic-links is recommended to prevent assorted security risks
symbolic-links=0


query_cache_size=100M
innodb_buffer_pool_size=200M
innodb_additional_mem_pool = 20M
join_buffer_size = 8M
tmp_table_size = 64M
sort_buffer_size = 8M
query_cache_limit =2M

innodb_buffer_pool_size=2M
innodb_additional_mem_pool_size=500K
innodb_log_buffer_size=500K
innodb_thread_concurrency=2
[mysqld_safe]
log-error=/var/log/mysqld.log
pid-file=/var/run/mysqld/mysqld.pid
innodb_buffer_pool_size=2M
innodb_additional_mem_pool_size=500K
innodb_log_buffer_size=500K
innodb_thread_concurrency=2

One that caused issue::

# The following options will be passed to all MySQL clients
[client] #password = your_password
port = 3306
socket = /var/lib/mysql/mysql.sock
# The MySQL server
[mysqld]
datadir = /var/lib/mysql
port = 3306
socket = /var/lib/mysql/mysql.sock
log = /var/log/mysqld.log
#log-bin = /var/lib/mysql/mysqld-bin.log
skip-locking
key_buffer = 128M
max_allowed_packet = 32M
query_cache_size = 10M
query_cache_type = 1
transaction_isolation=READ-COMMITTED
#max_binlog_size=1M
table_cache=270
tmp_table_size=70331648
thread_cache_size=15
#sync_binlog = 1
table_definition_cache = 290
bulk_insert_buffer_size = 15M
sort_buffer_size = 1M
read_buffer_size = 1M
myisam_sort_buffer_size = 64M
thread_cache = 16
expire_logs_days = 7
# Try number of CPU's*2 for thread_concurrency
thread_concurrency = 8
max_connections = 500
innodb_buffer_pool_size= 500M
innodb_log_file_size=135M
# Don't listen on a TCP/IP port at all. This can be a security enhancement,
# if all processes that need to connect to mysqld run on the same host.
# All interaction with mysqld must be made via Unix sockets or named pipes.
# Note that using this option without enabling named pipes on Windows
# (via the "enable-named-pipe" option) will render mysqld useless!
#
#skip-networking
# Replication Master Server (default)
# binary logging is required for replication
#log-bin=/var/lib/mysql/binary-update
#expire_logs_days = 7
# required unique id between 1 and 2^32 - 1
# defaults to 1 if master-host is not set
# but will not function as a master if omitted
#server-id = 2
#auto_increment_increment = 10
#auto_increment_offset = 1 # Replication Slave (comment out master section to use this)
#
# To configure this host as a replication slave, you can choose between
# two methods :
#
# 1) Use the CHANGE MASTER TO command (fully described in our manual) -
# the syntax is:
#
# CHANGE MASTER TO MASTER_HOST=<host>, MASTER_PORT=<port>,
# MASTER_USER=<user>, MASTER_PASSWORD=<password> ;
#
# where you replace <host>, <user>, <password> by quoted strings and
# <port> by the master's port number (3306 by default).
#
# Example:
#
# CHANGE MASTER TO MASTER_HOST='125.564.12.1', MASTER_PORT=3306,
# MASTER_USER='joe', MASTER_PASSWORD='secret';
#
# OR
## 2) Set the variables below. However, in case you choose this method, then
# start replication for the first time (even unsuccessfully, for example
# if you mistyped the password in master-password and the slave fails to
# connect), the slave will create a master.info file, and any later
# change in this file to the variables' values below will be ignored and
# overridden by the content of the master.info file, unless you shutdown
# the slave server, delete master.info and restart the slaver server.
# For that reason, you may want to leave the lines below untouched
# (commented) and instead use CHANGE MASTER TO (see above)
#
# required unique id between 2 and 2^32 - 1
# (and different from the master)
# defaults to 2 if master-host is set
# but will not function as a slave if omitted
#server-id = 2
#
# The replication master for this slave - required
#master-host = 192.168.0.100
#
# The username the slave will use for authentication when connecting
# to the master - required
#master-user = replica100
#
# The password the slave will authenticate with when connecting to
# the master - required
#master-password = replpass
#
# The port the master is listening on.
# optional - defaults to 3306
#master-port = 3306 #
# binary logging - not required for slaves, but recommended
#log-bin
# Point the following paths to different dedicated disks
#tmpdir = /tmp/
#log-update = /path-to-dedicated-directory/hostname
# Uncomment the following if you are using BDB tables
#bdb_cache_size = 64M
#bdb_max_lock = 100000
# Uncomment the following if you are using InnoDB tables
innodb_file_per_table
innodb_data_home_dir = /var/lib/mysql
innodb_data_file_path = ibdata1:10M:autoextend
innodb_log_group_home_dir = /var/lib/mysql
#innodb_log_arch_dir = /var/lib/mysql
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
# Set .._log_file_size to 25 % of buffer pool size
innodb_flush_log_at_trx_commit = 1
innodb_lock_wait_timeout = 800
innodb_flush_method = O_DIRECT
long_query_time = 10
log-long-format
log-slow-queries=/var/lib/mysql/slowqueries.log
#binlog_format = row
[mysqldump]
quick
max_allowed_packet = 32M
[mysql]
no-auto-rehash
# Remove the next comment character if you are not familiar with SQL
#safe-updates
prompt=[\\R:\\m:\\s]\u@\h:\d~>
[isamchk]
key_buffer = 128M
sort_buffer_size = 128M
read_buffer = 2M
write_buffer = 2M
[myisamchk]
key_buffer = 128M
sort_buffer_size = 128M
read_buffer = 2M
write_buffer = 2M
[mysqlhotcopy]
interactive-timeout 

I see that I have done some tweaks in the new my.cnf, but want to learn what caused the issue. Please help.

Thank you,

  • What does mysqld.err say? – Rick James Mar 14 '15 at 0:00
  • I missed to check the logs and I removed it when I got the answer. It was the line "innodb_log_file_size=135M" that caused the issue, but may I ask why? – prado Mar 14 '15 at 0:24
  • I edited my answer (which was mangled anyway). – Rick James Mar 14 '15 at 0:43
1

innodb_log_file_size -- Did you change that after running mysql? It cannot easily be changed. Recommend you set it back to what it was (or remove the line).

The are many answers on the web to "How do I change innodb_log_file_size".

"On startup, MySQL would not start if there was a mismatch between the value of the innodb_log_file_size configuration option and the actual size of the ib_logfile* files that make up the redo log". 5.6.8 fixes that.

  • Yes, I did it after moving the ib_logfile0, ib_logfile1 files(stopped the MySQL before moving them). – prado Mar 14 '15 at 0:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.