I have a simple stored procedure that I have just created.


I have applied this script to my database


This script shows up in the my list of stored procedure


However, when I restart MySQL workbench, its not in the list anymore


Interestingly, the procedure still exists even though it is not shown.

I can call

CALL LoadBatch ('057753') ; 

And get results

Whats going on, how can I see what stored procedure I have created?

I have tried clicking "Refresh All"


As Vérace has suggested

I have tried calling the LoadBatch command from the commande line


This seems to be unresponsive to my stored procedure.


After adding the ; character

Message OK

I think this stored procedure call worked ok from the command line

Here is the warning warn


I think this error message is important


  • 1
    User privilege issues? Are you always accessing the database with the same username/password combination? You should double check that you can create the procedure using just the command line and not MySQL Workbench.
    – Vérace
    Mar 18 '15 at 1:33
  • I'm always using the root account
    – sav
    Mar 18 '15 at 1:44
  • And if you use the command line?
    – Vérace
    Mar 18 '15 at 1:48
  • @Vérace Just trying to figure out how to do that
    – sav
    Mar 18 '15 at 1:50
  • 1
    CALL LoadBatch('057753'); (note semi-colon).
    – Vérace
    Mar 18 '15 at 2:04

I've just upgraded my MySQL server version and this problem is fixed.

It must have been an issue related to using MySQL Workbench with an older version of MySQL server.

  • The command line should have eliminated that problem - always go back to the command line if you get anomalous behaviour. Kindly mark your answer as correct - I don't think that you can do it immediately, but it will help others with similar problems if you do so.
    – Vérace
    Mar 18 '15 at 4:49
  • Yes, it always helps when you specify the versions of the used software. What server did you try first and what is your current MySQL Workbench version? Mar 19 '15 at 7:59
  • @MikeLischke I was using MySQL Server 5.5, upgraded to 5.6. I'm using workbench version 6.2
    – sav
    Mar 20 '15 at 0:25

Upgrading mySql server is not a fix for this issue.

The problem is probably caused by your database name using capital letters on Windows, and windows is case insensitive system.

It says in the server options file that you should use 'lower_case_table_names' property set to 2 in case of insensitive file system but even with this setting it still doesn't support capital letters in database names.

This is something mysql developers should look into.

  • This is partly correct. In Windows, you must use a lower case name for the schema/DB. However, you can use CamelCase for table, procs, etc.
    – user65762
    May 5 '15 at 12:06

I have a solution to Workbench not showing procedures and functions in tree view. ** This is due to the user lacking read privileges/permission to the data directory. **

My data installation is located in: /usr/local/mysql/data (Note: mysql is a symbolic link to the current installed version) The current user needs to have recursive read permission to the data directory (and sub-directories).

This change will enable the listing/display of the associated procedures and functions.


I have just update my version of workbench (community 6.3) and I'm using an older version of the server (5.1). I came out with a workaround :

  1. Just click on the i close to your db name.
  2. Then click on the 'Stored Procedures' tab at the right of the 'info' tab.
  3. Select the procedure you want to edit, right click on it and select 'Alter Stored Procedure' and you are in.

Hope it will help someone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.