0

We recently updated to mongodb 3.0.1 using the wired tiger storage engine, and have been using the genghis php admin ui through the browser. However, genghis is not completely working now, specifically it won't show collections available in the database. It seems the php call $db->listCollections() returns 0 collections. We are using the latest php mongo driver(1.6.5), and php 5.5.9.

Genghis will show collections for databases if we switch back to the mmap storage engine, so it looks like it might be something going on with how the php driver and listCollections() call works with the wired tiger storage engine? There are no errors in the apache or mongodb logs when I try browsing the databases with genghis.

I tried searching online and couldn't find any related problems, has anyone had problems with wired tiger + php like this?

closed as off-topic by Philᵀᴹ, Michael Green, Colin 't Hart, Paul White, Max Vernon Mar 25 '15 at 17:58

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Too localized - this could be because your code has a typo, basic error, or is not relevant to most of our audience. Consider revising your question so that it appeals to a broader audience. As it stands, the question is unlikely to help other users (regarding typo questions, see this meta question for background)." – Philᵀᴹ, Michael Green, Colin 't Hart, Paul White, Max Vernon
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Are you certain you are using the 1.6.5 PHP driver? Can you check via phpinfo() to be certain? If the listCollections() call isn't working with WiredTiger storage, this usually indicates an older driver that does not support the new listCollections server command required for WiredTiger in MongoDB 3.0. I just tried Genghis 2.3.11 with the 1.6.5 PHP driver and it works fine for listing collections with WiredTiger storage. – Stennie Mar 21 '15 at 1:39
  • I checked phpinfo() and php -i, both say the mongo php driver is 1.6.5. – djmongo Mar 23 '15 at 12:52
  • Hrm .. haven't been able to reproduce the issue. What version of Genghis are you running? Can you try to run a standalone test with just $db->listCollections() in a PHP script? – Stennie Mar 23 '15 at 21:05
  • I'm running the latest genghis, 2.3.11. I tried running $db->listCollections() in a separate script and it still returns zero collections :\. I don't know if this will matter, but I dumped the data with mongodump from the old mmap database and did a mongorestore to import it into the new database running with wired tiger. I don't know if this could cause a conflict or corruption in data possibly causing the collections to not get found? – djmongo Mar 24 '15 at 13:33
  • 1
    It looks like there's a new version of the mongo php driver out, 1.6.6. I updated to it and it looks like everything is working now. – djmongo Mar 24 '15 at 19:31
0

Updating to the latest mongo php driver, 1.6.6 fixed it.

sudo pecl upgrade mongo

Not the answer you're looking for? Browse other questions tagged or ask your own question.