I'm trying to test out the new SS 2012 RC, but I'm having problems with the installation.

My installation stops a ways in saying that the resource needed cannot be found. I'm using the ISO from MSDN and mounting it using MagicDisc. I browse to the location of the missing resource (vs_setup.msi) on the disc and it says that the vs_setup.msi file is not valid for VS 2010 Ultimate. I tried both vs_setup.msi's on the installation iso and both said they weren't valid. Any ideas on what I am doing incorrectly?

I do have VS2010 Ultimate already installed.

The dialogue specifically says:

The feature you are trying to use is on a network resource that is unavailable.

It tried to default to this directory, but the directory doesn't exist on my machine:


Browsing to the vs_setup.msi in E:\1033_ENU_LP\redist\VisualStudioShell\VSIntSetup and in E:\1033_ENU_LP\redist\VisualStudioShell\VSSetup doesn't work either.

Anyone have any suggestions for what I might be doing wrong?

migrated from stackoverflow.com Dec 22 '11 at 14:49

This question came from our site for professional and enthusiast programmers.

  • Hi Igor, did you comment on this? I see your name listed but no comment? Or was it you who highlighted those items? If so, thanks! It makes it more readable! – StoneFX Dec 22 '11 at 0:18
  • 2
    Apply SP1 to your VS 2010 installation prior to trying to install SQL 2012 RC0. – Shawn Melton Dec 22 '11 at 15:05

Download the Visual Studio 2010 ISO (Ultimate, in your case).

Extract it to a folder and use that folder path when prompted for vs_setup.msi.


Can I offer the suggestion of instead of mounting using MagicDisc to mount the ISO try unzipping the contents of the ISO using 7Zip. Once extracted just run the set up from within the extracted folder.

This was my install method and worked fine. Hope it helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.