0

I open the SQL Server Configuration Manager and it returns remote procedure call failed.

enter image description here

This is Windows 7 Ultimate version, SQL Server 2008 R2 Express version with advanced services.

Previously I installed SQL Server 2008 R2 Express version and since I needed the full text search I uninstalled SQL Server 2008 R2 Express and then installed SQL Server 2008 R2 Express with advanced services.

P.s my RPC background service is running.

I executed the following command and it returned an error:

 C:\Users\venkat>mofcomp.exe "C:\Program Files (x86)\Microsoft SQL    Server\100\Shared\sqlmgmproviderxpsp2up.mof"

 Microsoft (R) MOF Compiler Version 6.1.7600.16385
 Copyright (c) Microsoft Corp. 1997-2006. All rights reserved.
 Parsing MOF file: C:\Program Files (x86)\Microsoft SQL Server\100\Shared\sqlmgmproviderxpsp2up.mof
 MOF file has been successfully parsed
 Storing data in the repository...

Error:

An error occurred while processing item 1 defined on lines 4 - 7 in file C:\Program Files (x86)\Microsoft SQL Server\100\Shared\sqlmgmproviderxpsp2up.mof:
Error Number: 0x80041003, Facility: WMI
Description: Access denied
Compiler returned error 0x80041003

  • Is your Remote Procedure Call service running ? check under services.msc – Stijn Wynants Mar 25 '15 at 8:05
1

Try installing SQL Server 2008 R2 Service Pack 3, it worked with me.

1

In my case there were two instances of the "SQL server Configuration Manager" in SysWOW64. Only the latest version worked. The other version produced the RPC error message.

C:\Windows\SysWOW64\mmc.exe /32 C:\WINDOWS\SysWOW64\SQLServerManager10.msc FAILED
C:\Windows\SysWOW64\mmc.exe /32 C:\WINDOWS\SysWOW64\SQLServerManager11.msc WORKED
1

The problem is solved by running the command prompt as administrator and typing the same commands for me. Hope it helps

0

This error appears to happen when .mof files (Managed Object Format (MOF)) don’t get installed and registered correctly during set-up. To resolve this issue, Execute the following mofcomp command in command prompt to re-register the *.mof files:

I am generally write down according to bit size. which OS you are using according to that you can execute the command

mofcomp.exe "C:\Program Files (x86)\Microsoft SQL Server\100\Shared\sqlmgmproviderxpsp2up.mof"

  • I am using windows 7 ultimate version build 7610 sp1 – Venkat Mar 25 '15 at 9:15
  • updated after running your command. It returns an error. – Venkat Mar 25 '15 at 9:20
  • after executing the command , what you are getting error. can you share that error. – Md Haidar Ali Khan Mar 25 '15 at 9:51
  • 1
    Have you check out your OS, windows firewall and WMI privilege. – Md Haidar Ali Khan Mar 25 '15 at 10:00
  • For 32-bit mofcomp.exe "C:\Program Files\Microsoft SQL Server\100\Shared\sqlmgmproviderxpsp2up.mof" On a 64-bit operating system: mofcomp.exe "C:\Program Files (x86)\Microsoft SQL Server\100\Shared\sqlmgmproviderxpsp2up.mof" – Md Haidar Ali Khan Mar 25 '15 at 10:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.