1

I've installed Percona-Toolkit on my Debian (Wheezy) test Server, using

dpkg -i percona-toolkit.deb
apt-get install --fix-missing -f
dpkg -i percona-toolkit.deb

However, there is no sign of Innobackupex in the /usr/bin folder. Trying to run it simply gives me Command Not Found

I can see all the pt-xxx applications in there suggesting the installation worked ok.

I then tried

apt-key adv --keyserver keys.gnupg.net --recv-keys 1C4CBDCDCD2EFD2A

as per the documentation, but that resulted in:

. . .
gpgkeys: key 1C4CBDCDCD2EFD2A not found on keyserver    
gpg: no valid OpenPGP data found.
gpg: Total number processed: 0

Followed by

apt-get install xtrabackup

But that gave me

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package xtrabackup

How can I get xtrabackup (Innobackupex) installed as well?

1

It turned out to be an issue with our Proxy Server, blocking downloads from percona.com

Running sudo apt-get update revealed that every connection to percona.com 'failed', and so I got that added to the approved list, and after that it installed fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.