5

I have just set up very basic transactional replication on SQL Server 2014.

The Publisher and Distributor are one and the same.

I have configured the Publisher to push to the Subscriber, so any and all configuration was done on the Publisher.

I set up all of the user accounts exactly as detailed in this Microsoft Tutorial.

The Publisher and Subscriber are successfully set up, and SQL Server Agent is running on both servers.

Regardless of this, when I check the status on the Publisher, I repeatedly get this message:

The process could not connect to Subscriber '(subscriber-box)'

I've checked online, including here, here, here and here.

I've tried the suggestions and can't debug it, though I am pretty sure it's logon related.

2

Community Wiki answer generated from question comments by Brandon Williams

In the tutorial, the repl_distribution account will need to be added to the subscription database as db_owner.

In the New Subscription Wizard, on the Distribution Agent Security page, you specify a Process Account, which would be the repl_distribution account that was created on the Publisher. Now, further down on the page is a section 'Connect to the Subscriber'. Choose 'By impersonating the process account'.

If the account exists at the Subscriber with the same username and password, and appropriate permissions, it will work. This is known as pass-through authentication. Alternatively, you can use SQL authentication to connect to the Subscriber.

Response from dthree:

I tripled checked all of the security settings to make sure it was all set up right, and in that I found that I shared and set the security settings on the wrong folder for the repldata snapshot. Fixed that, and between both fixes it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.