0

Recently I have added binary logs to mysql to start replication but after that setting, mysql process failed to start and keep crashing constantly. In mysql error logs some messages are there but not guiding in any direction towards resolution.

replication setting on master

server-id              = 1
log_bin                = /home/ebsbkdrive/mysql_repl_data/mysql-bin.log
expire_logs_days       = 10
max_binlog_size         = 100M
binlog_format           = ROW

mysql version

mysql  Ver 14.14 Distrib 5.5.32, for debian-linux-gnu (x86_64) using readline 6.1

Platform

Distributor ID: Ubuntu
Description:    Ubuntu natty (development branch)
Release:    11.04
Codename:   natty

error that reported in error logs,

150401  9:28:22 [Note] Plugin 'FEDERATED' is disabled.
150401  9:28:22 InnoDB: The InnoDB memory heap is disabled
150401  9:28:22 InnoDB: Mutexes and rw_locks use GCC atomic builtins
150401  9:28:22 InnoDB: Compressed tables use zlib 1.2.3.4
150401  9:28:22 InnoDB: Initializing buffer pool, size = 10.0G
150401  9:28:23 InnoDB: Completed initialization of buffer pool
150401  9:28:23 InnoDB: highest supported file format is Barracuda.
150401  9:28:25  InnoDB: Waiting for the background threads to start
150401  9:28:26 InnoDB: 5.5.32 started; log sequence number 269850279391
09:28:26 UTC - mysqld got signal 11 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help
diagnose the problem, but since we have already crashed,
something is definitely wrong and this may fail.

key_buffer_size=16777216
read_buffer_size=131072
max_used_connections=0
It is possible that mysqld could use up to
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 456057 K  bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

Thread pointer: 0x0
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
stack_bottom = 0 thread_stack 0x30000
/usr/sbin/mysqld(my_print_stacktrace+0x29)[0x7f9e7008f349]
/usr/sbin/mysqld(handle_fatal_signal+0x483)[0x7f9e6ff54f33]
/lib/x86_64-linux-gnu/libpthread.so.0(+0xfcb0)[0x7f9e6ec9fcb0]
/usr/sbin/mysqld(_ZN9MYSQL_LOG17generate_new_nameEPcPKc+0x9b)[0x7f9e6ffe87ab]
/usr/sbin/mysqld(_ZN13MYSQL_BIN_LOG4openEPKc13enum_log_typeS1_10cache_typebmbb+0x204)[0x7f9e6ffec5a4]
/usr/sbin/mysqld(+0x284e21)[0x7f9e6fdbde21]
/usr/sbin/mysqld(_Z11mysqld_mainiPPc+0x59b)[0x7f9e6fdc0f3b]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xed)[0x7f9e6e2f676d]
/usr/sbin/mysqld(+0x27e2c5)[0x7f9e6fdb72c5]
The manual page at http://dev.mysql.com/doc/mysql/en/crashing.html contains
information that should help you find out what is causing the crash.

please check provided information and help me to resolve the issue.

  • this seems corruption to binary logs, move log-bin* to /tmp and then try to start. – Nawaz Sohail Apr 1 '15 at 11:55
  • Nawaz, are you referring path of binary log? that I have used custom rather than /var/log/mysql or something else, yet mysql process didn't started so no binary log not generated then how it gets corrupted? – HRK Apr 1 '15 at 12:05
  • what if you disable binary log option and then try to start to check if this happens since you only change this thing in your configurations. – Nawaz Sohail Apr 1 '15 at 12:13
  • exactly you picked it correct, when I comment this setting mysql job start normally, but with this setting on it keeps on crashing and whole this error dump keeps on repeating number of times. – HRK Apr 1 '15 at 12:22
  • use single quote to describe path of log-bin and then try..log-bin='path'..hope it get okay – Nawaz Sohail Apr 1 '15 at 12:30
0

I have resolved the issue, just thought to sharing in case it helps other in future in case face similar issue.

This is something have to do with apparmor and you don't qualify proper permission,

I have only qualify following in /etc/apparmor.d/usr.sbin.mysqld

/home/ebsbkdrive/mysql_repl_data/* rw

but was lacking read permission on folder itself

/home/ebsbkdrive/mysql_repl_data/ r

more precise first folder read itself followed by read-write within,

/home/ebsbkdrive/mysql_repl_data/ r
/home/ebsbkdrive/mysql_repl_data/* rw

I came to know this when I redirect logs to default location then it worked and also by closely looking how permission sets in armor file for default /var/log/mysql path.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.