1

The problem started where mongo wouldn't start because of low disk space. So I enabled the small files directive in the config file. Now it starts if I run:

/usr/bin/mongod --config /etc/mongod.conf

and it starts

service mongod start

and it fails from the same error about disk space, leading me to believe that it's just not reading the config file.

i added an echo statement to the upstart script and i see this:

Starting database: mongodstart-stop-daemon --background --start --quiet --pidfile /var/run/mongod.pid --make-pidfile --chuid mongodb --exec  /usr/bin/mongod  -- --config /etc/mongod.conf

Config file: https://gist.github.com/macdabby/3ee375be72ab3a3f11a7

Upstart script: https://gist.github.com/macdabby/192891a1ae690d4ec57c

Debian wheezy and mongodb 3.0.1

thanks in advance!

1

It seems as though it was reading the config file but reading it in a different way that it was ignoring a certain directive. I tried setting smallfiles to true which worked when starting manually. But in service mode I got it to work by disabling journaling. Not sure if this is a bug.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.