1

I thought I'd be clever and update my.cnf file to add ft_min_word_len=2 and didn't back it up first. I will never make that mistake again. Luckily, our project is still in production and no harm done.

I have no clue as to what I have done wrong in that file, as I cannot see any error logs (/var/log/mysqld.log). MySQL was running fine before I touched the config file - well, I assume it was.

By running the following command and restarting mysqld (service mysqld restart):

mv /etc/my.cnf /etc/my.cnf.backup

I got it up and running again - so that proves the config file is corrupt somehow. As soon as I put it back and restart the service it fails to start again.

This is probably not much help but this is my terminal screen showing the my.cnf file edited:

[mysqld]
local-infile=1
atadir=/var/lib/mysql
ft_min_word_len=2
socket=/var/lib/mysql/mysql.sock
user=mysql
# Disabling symbolic-links is recommended to prevent assorted security risks
symbolic-links=0 

innodb_buffer_pool_size=2M
innodb_additional_mem_pool_size=500K
innodb_log_buffer_size=500K
innodb_thread_concurrency=2

[mysqld_safe]
log-error=/var/log/mysqld.log
pid-file=/var/run/mysqld/mysqld.pid
innodb_buffer_pool_size=2M
innodb_additional_mem_pool_size=500K
innodb_log_buffer_size=500K
innodb_thread_concurrency=2

I can't see from this is what could have gone so wrong. I have tried removing the line I added, obviously.

What are my options here? How can I restore the original config file?

migrated from serverfault.com Apr 18 '15 at 18:13

This question came from our site for system and network administrators.

6

atadir=/var/lib/mysql

should be

datadir=/var/lib/mysql

  • Haha that highlights the newbie troubles I had navigating the config file using vim commands. Must have deleted a character!! Thank you very much. – PaparazzoKid Apr 5 '15 at 1:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.