I had Toad 11.5 and I'm trying to install Toad 12.6, to connect to Oracle 11g on a 64-bit Windows 7 machine.

No matter what I try, when I start Toad 12.6, I get the error: "No valid Oracle clients found. You need at least one 64-bit client properly configured." In the install, I used a downloaded win64_11gR2_client.zip file and it sure looked like it installed.

I've finally blitzed everything I could of Toad 11 and Oracle (using https://superuser.com/questions/256762/how-do-i-completely-remove-oracle-11g/762432#762432).

Somehow, I need to still install Oracle, or somehow set the Oracle Home. http://documents.software.dell.com/DOC220605 says how to edit the oracle home, but even when I had Toad 11 working, I couldn't get anything when clicking the ... button in 12.6, because "You do not have any Oracle homes installed."

I've tried installing the client directly, and I get an error about the path too long. I ignore the error and the install dies. From research, it has said that uninstalling the 32 bit client is the way to go. It doesn't appear to be the way to go.

What do I try next?

  • Did you verify that Oracle has been removed completely? I.e check if all Oracle folders, Registry entries, entires in PATH Environment variable and Services are gone? Commented Apr 22, 2015 at 6:17
  • @Wernfried - if the first link in my question is not complete, then it might not be all gone. But I did follow the directions in that first link, and it appears to deal with registry entries, PATH, etc. (However, I do suspect something messed up on my computer somewhere.) Commented Apr 22, 2015 at 15:46

2 Answers 2


Here's what worked, although I don't know if it's a good answer or not. I had someone who could log in as an admin on my pc do the Oracle client install. In other words, if you're not a full admin on your machine, it may fail, and not tell you why.

I had admin rights, I could edit the registry and path, but there were still some missing rights. Logging on as administrator and doing the install worked fine.


Delete all your Oracle Clients from machine and make a fresh installation.

In case you need both 32 bit and 64 bit follow this instruction: Stack Overflow - Install Oracle x86 and x64.

If you have problems to uninstall Oracle, follow this instruction: How can I completely uninstall oracle 11g?

  • This implies the install works. I can't get the install to get past the path check. Either the path is too long, I check the box to ignore it, and the install dies; or I've made the path shorter, and it dies when checking the path. The same thing happens when running from a command prompt and setting the -jreloc option Commented Apr 21, 2015 at 20:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.