0

I'm working through a Microsoft exam study book.

I have set up 2 SQL Servers (both 2012 Standard on Server 2008 R2) and a DC.

The book wants me to remotely connect SQL-A to SQL-B. Unfortunately the book doesn't say what to do if this doesn't work.

I can ping all servers from all servers.

Both SQL Severs are logged in with the same user who has admin rights but I can't connect the 2 SQL Servers.

Things I've tried from answers to similar problems:

  • Allow remote connections is ticked
  • Port 1433 is set as the TCP Port
  • Browser service is running
  • Firewall has an inbound rule set up.

I removed both SQL Servers from the domain and added them back in but that didn't change anything. I can't see what I've missed.

  • 3
    Have you tried enabling TCP/IP and named pipes ? "Start SQL Server Configuration Manager. In the tree pane, click Network Configuration to expand it, and then click Protocols for MSSQLServer/MyInstanceName In the results pane, verify that, under the Status column, Enabled appears next to the name of the TCP/IP protocol." msdn.microsoft.com/en-us/library/bb909712%28v=vs.90%29.aspx – Spörri Apr 22 '15 at 9:10
  • Named Pipes is Disabled but when I tried to enable it I got WMI Provider Error - Access is denied. [0x80070005] :\ – Nikewatch Apr 22 '15 at 9:19
  • Changed it as admin and it has worked. Thanks very much. All the best – Nikewatch Apr 22 '15 at 9:22
  • Spörri : As it is found useful and declared as answer, move your comments to reply area. – aasim.abdullah Apr 22 '15 at 10:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.