I've set up Replication between two remote servers, Using Peer to Peer & Transactional updates. The subscription is all set, but the actual replication doesn't take place.

When viewing the Synchronization Status of the subscription, i get an error, saying "The process could not connect to Subscriber 'SERVER2\DBINSTANCE'."

Clicking on start, this is the error message I get:

TITLE: View Synchronization Status

The agent could not be started.

For help, click: go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&ProdVer=10.50.1600.1&EvtSrc=Microsoft.SqlServer.Management.UI.ReplUtilitiesErrorSR&EvtID=CantStartAgent&LinkId=20476


An exception occurred while executing a Transact-SQL statement or batch. (Microsoft.SqlServer.ConnectionInfo)

SQLServerAgent Error: Request to run job SERVER\DBINSTANCE-DBNAME-DBPUBLICATION-SERVER2\DBNAME-3 (from User sa) refused because the job is already running from a request by Start Sequence 0. Changed database context to 'DBNAME'. (Microsoft SQL Server, Error: 22022)

For help, click: go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&ProdVer=10.50.1600&EvtSrc=MSSQLServer&EvtID=22022&LinkId=20476

Viewing the Agent History, trying to get more specific into the error, i get the following Error:

Error messages: The process could not execute 'sp_replcmds' on 'SERVER\DBNAME'. (Source: MSSQL_REPL, Error number: MSSQL_REPL20011) Get help: help/MSSQL_REPL20011 Cannot execute as the database principal because the principal "dbo" does not exist, this type of principal cannot be impersonated, or you do not have permission. (Source: MSSQLServer, Error number: 15517) Get help: help/15517 The process could not execute 'sp_replcmds' on 'SERVER\DBNAME'. (Source: MSSQL_REPL, Error number: MSSQL_REPL22037) Get help: help/MSSQL_REPL22037

I have looked each and every one of the errors online, went through all this kind of explanations and changes, and nothing worked. Many thanks to anyone who can pour some light on the issue.

  • Does the service account that your publisher is running under have proper permission on all your subscriber servers? Commented Dec 29, 2011 at 16:57

2 Answers 2


This is likely a permissions issue.

Verify that your replication agent accounts have the necessary permissions listed in the section Permissions That Are Required by Agents in Replication Agent Security Model.

  • Thank you for your answer, it helped, but I'm still receiving the same general error, but with a different specific error details: ------------------------------- Error messages: The process could not connect to Subscriber 'SERVER1\DBNAME'. (Source: MSSQL_REPL, Error number: MSSQL_REPL20084) Get help: help/MSSQL_REPL20084 Login failed. The login is from an untrusted domain and cannot be used with Windows authentication. (Source: MSSQLServer, Error number: 18452) Get help: help/18452 ------------------ Any thoughts? Thanks again!
    – Stewie
    Commented Jan 1, 2012 at 9:27
  • Can you try using a SQL login for the agent process account and see if that alleviates the issue? Commented Jan 1, 2012 at 21:12
  • You answer really helped me resolve the issue. In that case, I have already tried to use the SQL login for the agent process, but the windows one worked. So, using the windows one for the agents (all of them) have resolved the issue for me. Thank you!
    – Stewie
    Commented Jan 4, 2012 at 8:50


Not the answer you're looking for? Browse other questions tagged or ask your own question.