I'm using Oracle db, on Linux 64 bit server on Amazon cloud.

I'm getting following error when I run the connect command

SQL> connect / as sysdba
ORA-09925: Unable to create audit trail file
Linux-x86_64 Error: 30: Read-only file system
Additional information: 9925
ORA-09925: Unable to create audit trail file
Linux-x86_64 Error: 30: Read-only file system
Additional information: 9925

When I run this df -h command I'm not seeing the file system it's just showing as below

$ df -h
Filesystem Size Used Avail Use% Mounted on

I do not understand cause of this issue. Please let me know how to solve this issue

  • 1
    Seems that the filesystem on which the database is installed is readonly.?
    – Benoit
    Dec 21, 2011 at 16:09
  • Please update with output of mount (edit your question if possible)
    – kubanczyk
    Dec 29, 2011 at 23:00

4 Answers 4


Try this: connect to SQL*Plus, then do:

show parameter audit_file_dest

then exit SQL*Plus and do:

cd <path displayed above>
ls -ld .

What are the permissions? Ownership?

Perhaps a mounted filesystem has gone missing, and you don't have write permissions on the underlying mountpoint?


If the file system is missing then you haven't mounted it. You say that you are on Amazon, Have you created an S3 volume for your datafiles and software, or did you just use instance storage?

If the latter then the instance store is not persistent (See this for a related question).

If you have used an S3 volume is it presented to the vm and then mounted?


It seems to be a Linux issue, not an Oracle issue. The simplest solution, if possible, it to reboot your system.

If this does not solve the problem, note if there is anything interesting in /var/log/*.

If this turns into a system-related or filesystem-related question, ask it at Server Fault or, if you find it more appropriate, on unix.stackexchange.com

  • Mind-bogglingly, after searching here and there this is the only solution to my similar problem -- When trying to recreate a database (after Oracle "forgot" which control files it has created), for a particular SID I kept getting audit trail file errors even though other SIDs are fine. Until I restarted.
    – michel-slm
    Sep 19, 2012 at 4:14

Linux has an inbuilt mechanism to 'protect itself' when it detects hardware/os issues, hence the 'read only file system' message typically occurs when there are disk issues on the server in question and the server puts everything in read-only mode to protect against further corruption.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.