Linked Questions

33 votes
7 answers
76k views

Modify DEFINER on Many Views

I have am having problems backing up my databases after an update. I have been poking around on my system trying to figure out why. One query I ran returned this result. Got error: 1449: The user ...
Zoredache's user avatar
  • 483
49 votes
1 answer
78k views

Dump only the Stored Procedures in MySQL

I need to dump only the stored procedures : no data, no table creation. How can I do this using mysqldump?
nakhli's user avatar
  • 733
14 votes
2 answers
54k views

Can mysqldump dump triggers and procedures?

Is there any way of making a mysqldump which will save all the triggers and procedures from a specified db? Some time ago I read that mysqldump will also save my triggers, but it doesn't look like it....
dole doug's user avatar
  • 391
8 votes
2 answers
20k views

DROP PROCEDURE IF EXISTS not included in mysqldump

I'm dumping my stored procedures only using the following command: mysqldump --routines --no-create-info --no-data --no-create-db --skip-opt databasename -u username -p > outputfile.sql but the ...
nakhli's user avatar
  • 733
4 votes
2 answers
18k views

Is there any danger in granting SUPER privileges to a user?

I had problems in restoring procedures in my db, so what I did was to grant SUPER privileges to my dbuser. This user is the same user used in my web application, so I would like to know if there is ...
carla's user avatar
  • 603
2 votes
2 answers
2k views

Meaning of various user account privileges in phpMyAdmin

Reference the attached screenshot: I created a non-root user, and gave it all privileges to a database. It now has All Privileges of Type -- global and database-specific. What's the difference ...
thanks_in_advance's user avatar
2 votes
2 answers
3k views

MySQL Views Authorization

Questions: Is there a way, using SQL, to identify how many views are in the database per user? How can you authorize/deny users access to delete views created by another user?
neeraj's user avatar
  • 260
1 vote
1 answer
860 views

Unable to query for thread information in mysql using root

I'm connected to a server's mySql database hosted on google cloud using the user 'root' with a password. I was under the impression that the root user had all privileges but when I try to get the ...
user161733's user avatar
1 vote
1 answer
78 views

SlaveThreadCount at 0 for non-root user, should be 2

In MySQL 5.5 running on Ubuntu 14 in a master-master-slave configuration From one of the masters, when executing the query below as a user with (ALL PRIVILEGES) on the database but no other ...
Craig Efrein's user avatar
  • 9,640
0 votes
1 answer
97 views

How to get Super Priviledge for a database on an online server

Can someone please look at this MySQL statement and suggest to me what to do, for each time I run the code below, I get the following error: 1227 - Access denied; you need the SUPER privilege for ...
erabxes's user avatar